Repair thermoelectric cooler

Discussion in 'The Projects Forum' started by wayneh, Sep 23, 2014.

  1. wayneh

    Thread Starter Expert

    Sep 9, 2010
    12,153
    3,059
    Looking for advice on what to look at, how to repair an appliance.

    A friend picked up a small wine cooler at a garage sale, for free because it was not running. She figured I might fix it. So I went after it.

    Here's what I know so far. This is a ~70W peltier refrigerator. It uses 2, 12V computer-type fans on the hot side of the heat sink and I think just one on the cold side. One of the hot fans has seized - very stiff to turn by hand - and its power lead had lost insulation where it may have rubbed against the edge of the heat sink. I disconnected the bad fan and replaced a 2.5A soldered-on fuse on the controller PCB with a 2.0A fuse I had on hand. When power was reapplied, the internal fan came on briefly but soon the fuse blew again and a puff of smoke rose off the PCB !!!

    Unfortunately I was looking inside the unit and was unable to see where the smoke had come from. There is nothing obviously wrong on the board except the blown fuse.

    I unsoldered the TEC leads and checked the resistance - I get about 0.8Ω (not a dead short) but my cheap meter is not reliable at such low ohms. When Peltier units fail, do they fail to a short?

    Also connected by jumpers to the PCB are the hot and cold fans, an NTC temperature probe, AC power, and an LCD control panel for adjusting the temperature set point.
     
    Last edited: Sep 23, 2014
  2. wayneh

    Thread Starter Expert

    Sep 9, 2010
    12,153
    3,059
    The unit is an Emerson FR966 built in 2008. The back panel says it is 1A, 70W, 1.2cu.ft.
    The control board is marked Foshan Hanyi Computer Device Co. Ltd. PCB70323E1 FX-101. There are other markings.

    I gather from a brief search that the FX-101 PCB is impossible to find, and I haven't seen any suggestion of an alternative.

    It shouldn't be too hard to find a TEC controller that would work? It would be great to maintain the LCD readout but in reality that's a set it and forget it thing. I could manually set the temperature if needed.

    Is it fair to assume the SMPS on the PCB is too hard to diagnose? Just wondering how to proceed.
     
  3. MrChips

    Moderator

    Oct 2, 2009
    12,449
    3,365
    Let's assume that the unit is 100% efficient and thus the TEC is rated at 70W.
    Without knowing the operating voltage and current of the TEC, 6A x 12VDC =72W. Hence the resistance should be in the order of 2-ohms.
    Sounds like the TEC is shot.

    If you have a variable bench supply that can deliver 0-12V @3-6A, disconnect the TEC from the controller and apply power to it while gradually increasing the voltage from 0V. At about 6VDC you should be able to feel some temperature differential.
     
  4. wayneh

    Thread Starter Expert

    Sep 9, 2010
    12,153
    3,059
    My power supply isn't up to that much current, but I can put a headlight in series with a car battery and see what happens. It may be easier to pull out the TEC first, to feel both faces when power is applied.
     
  5. wayneh

    Thread Starter Expert

    Sep 9, 2010
    12,153
    3,059
    The TEC draws only about 4.2A off my 12V tractor battery, so that shouldn't cause a problem. I didn't run it long enough to feel heating or cooling on the fins. My headlight drew ~2.5A by itself and about 1.9A with the TEC in series. All as measured with my cheap Harbor Freight meter in 10A ammeter mode.

    The remaining fans spin under power and draw less than 100mA each, ruling them out. The NTC shows 13.1KΩ at ambient temp, reasonable.

    So I hooked it all back up and touched a jumper across the fuse (which blew in a few seconds last time, not immediately, so I thought a brief touch would be OK). Well that was exciting. One of the power transistors popped and split in half, releasing the magic smoke. OK, saw that! There's an identical transistor next to it, and I've pulled both for replacement. There's a diode nearby that looks like it may have gotten hot - I'll check that too.

    The transistors are marked 13005-2, and this appears to be a 700V, 4A NPN switching transistor. Makes sense. Looking for replacements. This transistor looks like a reasonable replacement?

    My board looks very much like this one. The blown transistor is on the heat sink just above the one on the lower right I had to remove the big cap to access the lower one The cap holds a 12V charge just fine and seems to be fine. The fuse is at the lower left just above where the AC jumper attaches. Another 5A fuse - not blown - is inside black tubing just above the copper-wound toroid middle right. The TEC connects to those two holes just above that. The upper left connecter is for the NTC, middle 3-conductor is for the control panel, and the two on the right are for the hot and cold fans.
    Screen Shot 2014-09-22 at 7.29.07 PM.png
     
    Last edited: Sep 23, 2014
  6. wayneh

    Thread Starter Expert

    Sep 9, 2010
    12,153
    3,059
    I've also found that although this particular board is not available, many thermoelectric wine cooler brands use almost the same board and are almost identical inside. Just different branding. This is very similar to mine.

    This transistor looks like a reasonable replacement?

    Every diode on the PCB tests good in-circuit; ~600mV forward drop in one direction, nothing in the other, using my multimeter's diode setting.
     
    Last edited: Sep 23, 2014
  7. KJ6EAD

    Senior Member

    Apr 30, 2011
    1,425
    363
    Okay, what about the other large capacitor on the left?
     
  8. wayneh

    Thread Starter Expert

    Sep 9, 2010
    12,153
    3,059
    It's still in-circuit but does appear to hold a voltage that drains away as I measure it. It's definitely not shorted. No appearance of bulging or leaking.

    I did find a report online of a guy that fixed his PCB by replacing all the caps. My cooler is only 6 years old, so I'm a little skeptical that the caps are bad. But I am making a list of them and I may add them to my parts order.
     
  9. alfacliff

    Well-Known Member

    Dec 13, 2013
    2,449
    428
    I fix several smps every day, mostly caps and some as young as 3 years. if a fan quit, it could have gotten hot, that makes the caps go bad sooner. if no evidence of bulging caps, or leaking chemicals underneath, they can still be bad.
     
  10. wayneh

    Thread Starter Expert

    Sep 9, 2010
    12,153
    3,059
    Alright, I'm convinced. Do you pull them all and test them, or just replace them, or test them in circuit? Looks like 16 total 'lytics on the PCB. Maybe just 6 on the power side of the board.

    Here are photos of my actual board. The board is split into two sections by that big aluminum sink in the middle. Everything except the AC power is attached to one end (first photo). The TEC is wired to the empty holes at middle left. The lower photo shows where the two power transistors have been removed along with one big capacitor. The black wires go to a temporary fuse holder. The original fuse was soldered in.

    IMG_0239.jpg


    IMG_0240.jpg
     
    Last edited: Sep 25, 2014
  11. wayneh

    Thread Starter Expert

    Sep 9, 2010
    12,153
    3,059
    Most of the capacitors on the PCB are labelled CD81 and manufactured by Aishi. I can't seem to find what the CD81 means. Are these just "general purpose"?

    The big caps are labelled HY CD288H, and that apparently means they are rated for low impedance, wide temperature usage. High-power switching. Makes sense.
     
  12. wayneh

    Thread Starter Expert

    Sep 9, 2010
    12,153
    3,059
    Today my new transistors arrived. I replaced them, the fuse and the capacitor I had removed, and put all the connections back together.

    And....

    Nothing. Grrrr..

    The fuse does not blow but nothing else works. The failed transistor must have taken some other things with it. There appears to be no DC power to the board - no fans, no power to the front LCD control panel, nothing to the TEC.

    Any ideas? I'm thinking it's time to pull the plug on this job unless there are some "obvious" things to try.

    I could make the cooler work without the front panel control by just using my own thermostat. Not as fancy but it would salvage most of the functionality of this thing.
     
  13. wayneh

    Thread Starter Expert

    Sep 9, 2010
    12,153
    3,059
    Just found out there is nearly ~600V AC on the collector of the transistor that had blown !! (upper of the two in the photo above). It shows up as ~280V on the DC range of my meter. Wasn't expecting that. My probes are too big and my hands are nowhere near steady enough to be probing tiny pins with that sort of voltage on them. Backed away slowly and unplugged it.

    Anyway, I'm thinking of pulling all the electrolytics for testing. All I can do is pulse them up to 12V and watch as the voltage decays on my multimeter. Is that enough?
     
  14. wayneh

    Thread Starter Expert

    Sep 9, 2010
    12,153
    3,059
    Success! It works again.

    I may never know exactly where the problem was but that's OK. The power transistor had certainly blown, and its base resistor had failed to open, like a fuse. I replaced those parts and then I replaced every single electrolytic cap on the PCB. Some had an ESR much higher than their new replacements, for example 30Ω versus 1Ω.
     
    smerk likes this.
  15. Mike Howard

    New Member

    Dec 18, 2014
    7
    0
    Hey Wayneh,

    I have the exact same mini cooler, with apparently the same problem. When plugged in, the main control panel just beeps and flashes. The board you show is the exact board that is in my unit. Do you have a parts list for the items you replaced? I'm sure I need to perform the same repair you did.

    In addition, I found that if I disconnect the peltier, then the unit powers up normally and the fans all turn on. Seems the peltier is taking too big of a load on the power supply. The peltier checks out fine so it must be the PS.

    Mike
     
  16. Mike Howard

    New Member

    Dec 18, 2014
    7
    0
  17. Mike Howard

    New Member

    Dec 18, 2014
    7
    0
    OK, so here is my parts list to try and repair the Emerson FR966 Wine Cooler. I think these are as close as I can get, given I measured the lead spacing and the size of each cap. Also, I did some Googling to come up with the Transistors and the Schottky. Going to place the order today, looks like about $14 for all the parts (actually $28 because I am ordering double).

    2 - 120uf 200v caps (Digikey #493-4799-1-ND)
    4 - 4.7uf 50v caps (Digikey #P15148-ND)
    3 - 1uf 50v caps (Digikey #P15155-ND)
    2 - 22uf 25v caps (Digikey #P15803CT-ND)
    4 - 47uf 25v caps (Digikey #P15141-ND)
    1 - 1000uf 16v cap (Digikey #493-1044-ND)
    2 - NPN Transistor (Digikey #568-8367-5-ND)
    1 - Schottky Diode/Rectifier (Digikey #SBL3040PT-E3/45GI-ND)

    What I'd really like to do is get rid of the PS/Controller combo and replace it with something more generic. Maybe something like:
    AspenTek Us Plug 12vdc 6a 72w
    http://www.amazon.com/dp/B00GU63ICU...TF8&colid=2ALEEWKIXS6W8&coliid=I3PS6B6FQ2YTM5

    And then a temp controller that would utilize the existing NTC and front mounted temp control board...but for now I'll just try to get this thing cooling again.
     
  18. wayneh

    Thread Starter Expert

    Sep 9, 2010
    12,153
    3,059
    Sorry for the slow reply. Charter cable has been out in my area for 2 days!

    I'll send you a message with my parts order from Newark. You'll see that I ordered extras of the items that were cheap and/or on sale.

    Here is the capacitor list:
    No. µF Voltage
    3 1 50
    4 4.7 50
    2 22 25
    4 47 25 (replaced with 47, 35V)
    2 120 200 (replaced with 150, 250V)
     
  19. Mike Howard

    New Member

    Dec 18, 2014
    7
    0
    Great. I went ahead and ordered the transistors and the schottky just in case. I'm going to replace the caps one side at a time to see which caps, or combination of caps, fixes this thing, starting with the PS side. None of my caps look bad and there are no obvious signs of distress on the board. It just seems the caps have gone bad and the PS can't supply the proper voltage any longer.

    It's funny that there are a lot of folks out there looking for reasons why these mini fridges are going bad, but there is no info other than "replace the board" which you can't find or is dang near $100. I've looked around for alternatives from other manufactures like Haier, Vinotemp, etc.. to see if I could swap out the board with something that is almost the same, but its hard to find a dual fan header, NTC and 3 pin temp control connector at a decent price.
     
  20. RABSP

    New Member

    Jan 12, 2015
    4
    0
    Just noticed tonight that my wine fridge was very quiet, and so it seems to have a similar issue. My board is the FX-102, one of the two big switching Transistors is short as well as one for the bridge diodes, the big cap that is removed in the pic above is looking ever so slightly swelled, and of course the main Fuse is blown. I have fixed a lot of SM power supplies and it usually starts with the start caps. Mike, How are you going with your replacements? Have any of these started up after the parts replacements? the two small transistors look ok I guess if I can replace the big stuff before replace the fuse and make things worse, I have a better chance.
     
Loading...