Recommendations for pre-run maintenance

Discussion in 'General Electronics Chat' started by Gdrumm, Apr 23, 2015.

  1. Gdrumm

    Thread Starter Distinguished Member

    Aug 29, 2008
    684
    36
    A roadside find today, a Sharpe "Bear Cat" portable air compressor.

    It looks antique, was made in Los Angeles, MN may be BC21705.

    Someone removed the on-off switch, and wired it direct to the plug (cord has been replaced).

    It has oil cups at the motor bell ends, so I put a few drop of transmission oil in each cup.

    I can't see oil in the compressor yet (sight gauge is real cloudy).

    I think I can deal with the compressor but wondered what precautions I might need to take on the motor side, being that it's probably 50 + years old.

    I would say it's been kept dry, so should I just plug it in and see what happens?

    Any insights would be appreciated, it's a really cool looking compresor, and I would like to salvage it if I can.

    Thanks,
    Gary
     
  2. wayneh

    Expert

    Sep 9, 2010
    12,088
    3,027
    If it's not too hard, I'd decouple the motor from the crank, so that if the motor runs you'll see it spin freely. You might be able to turn the crank by hand to verify that it and the piston(s) are not seized.

    Otherwise, I fear the worst case will be a nice 60Hz hum with no motion. I guess that wouldn't be so bad, but then you'd be on to diagnosing it.
     
  3. Gdrumm

    Thread Starter Distinguished Member

    Aug 29, 2008
    684
    36
    I still haven't given it any juice yet.
    I drained the compressor crankcase, and a redish fluid came out, maybe one cup full, looked pretty clean, a little sludge.
    This weekend, I'll work on it.
    I will disconnect the motor, and if it and the compressor turn over by hand, that would be a great start.

    I'll post back, thanks for the suggestions.
    Gary
     
  4. Gdrumm

    Thread Starter Distinguished Member

    Aug 29, 2008
    684
    36
    Update,

    It's running, and it does compress air (I haven't gone above 60 psi yet).

    There is a oil seal leak at the back of the compressor, I may try some Stop Leak, rather than tear it down.

    The motor runs great.

    Thanks for the advice.

    Gary
     
    wayneh likes this.
Loading...