Receiving "time step too short" error when trying to run simulation in LTSpice

Discussion in 'The Projects Forum' started by penchansky.e, Feb 26, 2016.

  1. penchansky.e

    Thread Starter New Member

    Feb 26, 2016
    1
    0
    Hi,

    Right now I am trying to run a simulation in LTSpice and receiving the error, "time step too short" error. However, the value it shows me for the timestep being used does not seem to correspond with what I had set for the maximum timestep through the Edit Simulation Cmd in the program. Would anyone be able to help advise me as to what to do?
     
  2. Alec_t

    AAC Fanatic!

    Sep 17, 2013
    5,804
    1,105
    I understand the message occurs when a voltage/current transient is too steep for LTS to resolve (but I'm a relatively new convert to LTS, so that may not be the case). Sometimes just tweaking a component value/parameter slightly solves the problem. I've not found changing the maximum timestep value to help, and don't see why it would. I'd love to know if there's a consistent cure.
     
  3. eetech00

    Active Member

    Jun 8, 2013
    650
    112
    There are many possible causes for the error message.

    Post your schematic or the LTspice .asc file.
     
  4. Veracohr

    Well-Known Member

    Jan 3, 2011
    552
    76
    I hate this error. Sometimes just changing the simulation time fixes it.
     
  5. crutschow

    Expert

    Mar 14, 2008
    13,045
    3,244
    And sometimes selecting the Gear or Trapezoidal Integration method in the Spice tab under the Tools/Control Panel will help.
     
  6. Alec_t

    AAC Fanatic!

    Sep 17, 2013
    5,804
    1,105
    Could you list a few please?
     
Loading...