Push Pull Config problem!!!!

Discussion in 'The Projects Forum' started by pppopey, Oct 9, 2011.

  1. pppopey

    Thread Starter New Member

    Sep 27, 2011
    13
    0
    Hi everyone

    Im facing a problem. I am not able to understand the push pull configuration in this schematic. When I make this circuit on the breadboard, the circuit works till the PWM generator and doesn't work after the BJT, mostly there is a SC in this circuit even if connected properly. If i remove the 3 BJTs and attach the PWM straight to the mosfet,. the circuit works. But i need to have a drive circiuit and I've been told that this push pull drive circuit is good.

    Please tell me why it is not working and some solutions to improve this drive circuit or any other options, EXCEPT using a microcontroller.

    Thanks :)
     
    • cct.jpg
      cct.jpg
      File size:
      175.9 KB
      Views:
      27
  2. t_n_k

    AAC Fanatic!

    Mar 6, 2009
    5,448
    782
    In principle it should work fine. Have you checked the individual integrity of each of the BJT's?
     
  3. mik3

    Senior Member

    Feb 4, 2008
    4,846
    63
    Remove TR2, if TR3 and TR4 are fine, then the MOSFET will be ON. If it is OFF then TR3 is not good. If it is ON then there is a great chance that TR2 is not good.

    Also, remove TR2 and connect R9 between the outptu of IC1/2 and the input of the push-pull. If it works then, TR2 is not good.

    Without removing anything:

    If the output is always high, then TR2 is bad or its base is shorted to ground.

    If the output is always low, then TR2 is shorted is TR3 is bad (I am not saying TR4 is shorted since it would cause a large current when TR3 turns ON).
     
Loading...