Pspice Simulation issue

Discussion in 'General Electronics Chat' started by Orien Walker, Aug 3, 2016.

  1. Orien Walker

    Thread Starter New Member

    Aug 1, 2016
    27
    0
    Using a lite version of pspice and the entire simulation section is deactivated and it wont allow me to simulate anything. does the lite verson not allow for actual circuit simulation?
     
  2. SLK001

    Well-Known Member

    Nov 29, 2011
    810
    224
    It will simulate, but you have to use the parts that PSpice provides in the lite version.
     
  3. Orien Walker

    Thread Starter New Member

    Aug 1, 2016
    27
    0
    Ok, i imported a model of the chip I'm trying to simulate from TI's website. is that whats causing the issue?
     
  4. SLK001

    Well-Known Member

    Nov 29, 2011
    810
    224
    Is the TI chip model in the libraries supplied by PSpice?
     
  5. Orien Walker

    Thread Starter New Member

    Aug 1, 2016
    27
    0
    no, i had to download the file from TI after the fact. It was not part of the original pspice libraries.
     
  6. crutschow

    Expert

    Mar 14, 2008
    12,977
    3,221
    Try LTspice.
    It's free and allows addition of outside models of any kind.

    But I'm surprised that you PSpice is completely deactivated because of an added model.
    You may have a different problem.
    Does it work if you remove the model?
     
  7. Orien Walker

    Thread Starter New Member

    Aug 1, 2016
    27
    0
    I've tried LTspice, it doesnt have the option to add in the module i need. it comes with a lot of LT modules, but nothing from TI. and i cant find a LTsoice compatible module for the device i need. It might be another problem, but i used pspice in school and never had this issue. i started a new schematic, added all my parts, connected my circuit, assigned values and it wont allow me to run it, save it or interact with the schematic on any analytical level.
     
  8. crutschow

    Expert

    Mar 14, 2008
    12,977
    3,221
    What is the module you can't add to LTspice?
     
  9. Orien Walker

    Thread Starter New Member

    Aug 1, 2016
    27
    0
    A TI LM3401 Hysteretic PFET Controller for High Power LED Drive
     
  10. Alec_t

    AAC Fanatic!

    Sep 17, 2013
    5,767
    1,102
    The TI model for that is encrypted :(.
     
  11. Orien Walker

    Thread Starter New Member

    Aug 1, 2016
    27
    0
    What does that mean Alec? it allowed me to import it into my schematic and wire it up. is the encryption why i cant sim anything?
     
  12. Alec_t

    AAC Fanatic!

    Sep 17, 2013
    5,767
    1,102
    I don't use Pspice, so not sure what the encryption does there. Can't work out how to use the model with LTspice though.
     
  13. Orien Walker

    Thread Starter New Member

    Aug 1, 2016
    27
    0
    what software would you suggest for circuit simulation and PCB design?
     
  14. Orien Walker

    Thread Starter New Member

    Aug 1, 2016
    27
    0
    I'm stuck between eagleCAD and using its bridge to LTspice or the OrCAD pspice suit.
     
Loading...