PSPICE circuit Problem

Discussion in 'Homework Help' started by bumclouds, May 18, 2008.

  1. bumclouds

    Thread Starter Active Member

    May 18, 2008
    82
    0
    Hey guys,

    I'm trying to simulate the below circuit:

    [​IMG]



    I'm drawing it up in PSPICE for an AC sweep and transient analysis, but its producing really strange results which contradict the transfer function I have calculated on paper several times.

    [​IMG]


    Is there anything you can see that is immediately wrong?
    PS: Beta = 100

    Thanks!
     
  2. Audioguru

    New Member

    Dec 20, 2007
    9,411
    896
    What is F4?
    Is it an optically coupled transistor? Then it has no power supply and it has no load resistor.
     
  3. bumclouds

    Thread Starter Active Member

    May 18, 2008
    82
    0
    ^ F4 is a current-controlled current source of gain=100.
     
  4. JoeJester

    AAC Fanatic!

    Apr 26, 2005
    3,373
    1,157
    You mean something like this?
     
  5. bumclouds

    Thread Starter Active Member

    May 18, 2008
    82
    0
    i found a solution to my problem. it wasn't how i was drawing the circuit, it was that my AC sweep needed to go back before 1 rad/s in order to detect the first pole.

    PS: JoeJester what exactly is that circuit that you've provided and how come it's exactly the same as the one in my assignment?
     
  6. JoeJester

    AAC Fanatic!

    Apr 26, 2005
    3,373
    1,157
    My circuit is your circuit.

    You had a Current Controlled Current Source with a gain of 100. It used the current in the capacitor (Ib). I used the information you provided.

    In your drawing you just indicated Ib and the CCCS was beta Ib. The CCCS symbol used in my spice is probably what confused you, as it is required to sample the current (left side of the symbol) to provide the output.
     
Loading...