PS-26KX Pyramid PSU

Discussion in 'The Projects Forum' started by KC5TDG, Jun 1, 2009.

  1. KC5TDG

    Thread Starter New Member

    Jun 1, 2009
    3
    0
    I have a pyramid PS-26-KX PSU. This unit was accidently shorted across the DC plugs. I have replaced 2 of the 4 2n33055 power transistors, 3 of them tested bad, but due to someone's prior work, one of them was not making connection and therefor was still good. I only have 3 transistors connected at this time, as radioshack only have 2 in stock. I have removed the 4th completly and isolated the wires for it so they do not short to anything/each other. I also fixed some bad solder joints on the circuit board.

    But of cource when I turn the unit on. I get the blinking red light and the buzzer going off. I have removed the TIP41C, it tested good so I put it bad in. All resistors in section RB of the schematic are good. The TYN416 SCR tests good. To the best I can tell with an analog test meter, the 16V zener diode is good as well. There are also no shorts in capacitor bank CX, with all power transistors removed, I do get 20v out of the rectifier.

    Im almost at my ends with this unit. I do notice that looking at the section DA on the schematic it shows a total of 4 1n4002 diodes. However on my circuit board that are only two, can someone PLEASE take a photo of the circuit board if they have one of these units and post it for a reference. It is possible the someone worked on this after it was shorted, but he cannot tell me what if anything he did to it as far as removing/changing stuff.


    thank you,

    KC5TDG
    bolwire@cableone.net
     
  2. SgtWookie

    Expert

    Jul 17, 2007
    22,182
    1,728
  3. KC5TDG

    Thread Starter New Member

    Jun 1, 2009
    3
    0
    Thanks for your prompt reply. The photos of the ps-36 are somewhat helpful. I have included a few photos of my ps-26 in order to show more detail. One main thing I notice is the board on the ps-36 doesn't have the relay at the bottom right, my board does, so there are going to be a few differences, so I would hate to make a decision based on those photos.

    component_side_a is plain photo
    the other two I have drawn a red box around the wire in question. you can also see that this is mainly of section DA, and when comparing to the schematic, two diodes are actually missing, but Im not sure if those two diodes are only used in the ps-36 model, as they are present in the photos at the links you provided. Sorry for the large photos, Im new and dont know how to arrange them nicely.

    thank you,

    JAMES KC5TDG
    bolwire@cableone.net
     
    Last edited: Jun 1, 2009
  4. SgtWookie

    Expert

    Jul 17, 2007
    22,182
    1,728
    It's going to be up to someone else to help you. Sorry, but I'm on my way out of town for awhile.
     
  5. KC5TDG

    Thread Starter New Member

    Jun 1, 2009
    3
    0
    Solved, replaced bad 1n5393 diode at D5.
     
Loading...