project need some help

Discussion in 'The Projects Forum' started by Big Zee, Jul 7, 2013.

  1. Big Zee

    Thread Starter New Member

    Jul 7, 2013
    3
    0
    hello

    this project took a lot of money and a lot of time
    but when I done of every thing
    the output of the power supply doesn't work as planed
    the project should be adjustable of the voltage and the amp
    but the ICs keep burning and the output cant be adjusted
    I tried to simulate it on circuit wizard and its fine in some of the part of it
    but the output wont be satiable at all
    its show its adjusted to 13 volt and that's ok then its jump to 50volt down slowly to 13 over and over and over

    please I need help on this
    what went wrong

    x2.JPG

    x4.JPG

    0V-30V_modified_PS_latest.jpg

    IMG_4648Xx.jpg
     
  2. bountyhunter

    Well-Known Member

    Sep 7, 2009
    2,498
    507
    Bad design. That 28VAC transformer is probably going to be putting out close to 50VDC at light load currents which will blow up the op amps.
     
    Big Zee likes this.
  3. donpetru

    Active Member

    Nov 14, 2008
    186
    25
    Big Zee likes this.
  4. bountyhunter

    Well-Known Member

    Sep 7, 2009
    2,498
    507
    It would be a lot easier if Q2 was a PNP and then the driver ICs could connect to a small NPN to pull down to drive the power transistors. You could use a lower voltage rail to run the control circuitry.

    No offense to the original designer, but that design is an exercise in doing everything the hard way.
     
    Big Zee likes this.
  5. Big Zee

    Thread Starter New Member

    Jul 7, 2013
    3
    0
    donpetru
    I will try your design soon

    bountyhunter
    now its BD136 PNP and its stable
    but I cant adjust it
    the other thing its overflow (error) after few seconds with 999volts :confused:

    x5.JPG

    x6.JPG
     
    Last edited: Jul 7, 2013
  6. Big Zee

    Thread Starter New Member

    Jul 7, 2013
    3
    0
    donpetru

    I did your PS (simulation )
    and its almost perfect
    yes its sets perfect and its stable and adjustable
    but its jump to 35v and goes down to the correct voltage every few minutes !
    why is that ? can I improve it ?
    thx

    x7.JPG
     
Loading...