Problems interfacing with RT204-1 LCD

Discussion in 'Embedded Systems and Microcontrollers' started by bobbylight, Apr 19, 2011.

  1. bobbylight

    Thread Starter New Member

    Apr 18, 2011
    4
    0
    I am currently using a HD44780U (LCD-II) to display some statistical data. It displays without any issues and is 2 lines by 8 characters. The new LCD I would like to use is the RT204-1 (VER2.0) and the associated data sheet is:

    http://www.satistronics.com/myfiles/file/LCD/RT204-1.pdf

    I am new to using datasheets but it appears that the pinouts are identical for both displays. I tried adjusting the wait time after power on. Does anyone have any other suggestions?
     
  2. guitarguy12387

    Active Member

    Apr 10, 2008
    359
    12
    You probably want to look at the timing diagrams of the control signals... i'd be surprised if this is simply a drop in replacement...
     
  3. bobbylight

    Thread Starter New Member

    Apr 18, 2011
    4
    0
    I have tried adjusting the timing so that it would be longer (the data sheet says timing is the same). The control signals are different, I realized this last night and changed them around but that didn't help any. I still get what looks like metastable behavior. It seems like either the LCD is fried or I am not using the correct initialization instructions.
     
  4. guitarguy12387

    Active Member

    Apr 10, 2008
    359
    12
    Let me preface by saying that i'm not in any familiar with either of these LCDs, but i'll try to help!

    Where are you observing metastable behavior? What signals/conditions?
     
Loading...