Problem with printing size with HP P1102 W

Discussion in 'General Electronics Chat' started by thumb2, Dec 13, 2015.

  1. thumb2

    Thread Starter Member

    Oct 4, 2015
    66
    4
    Hi all,

    I recently bought an HP P1102 W (which is a laserjet printer) for my home made PCBs.
    Unfortunately, I got a surprise after printing a board: the size of the DIP package mismatch from the one on KiCAD (I use it on Linux)

    I always test the size putting the printing preview to scale 1 and put the IC on the monitor (it's a flat motinor) to make me an idea if I am doing something wrong. The other way is to print on a paper first.

    But when I do the final print on transparency paper (but seems the paper size does not matter), the size of the footprint just mismatch. :eek:

    Here's a foto I made:

    [​IMG]

    Do someone had similar problems with my same printer (or with an other one) ?

    The printing options are set to accurate scale 1. I always print to PDF first than print on paper.

    Regards
    thumb2
     
  2. thumb2

    Thread Starter Member

    Oct 4, 2015
    66
    4
    Solved ! I have to print straight from KiCAD without exporting it to PDF first.
    Maybe the bug is into the PDF reader (I am using evince). Well, now it match right.

    thumb2
     
  3. spinnaker

    AAC Fanatic!

    Oct 29, 2009
    4,866
    988
    Also remember to check if you want to mirror or not mirror when you print. If I recall Express PCB requires you to mirror. But Diptrace requires no mirroring. I etched a whole board printed with Diptrace. Started placing the parts. Only then did I realize it was wrong! :(
     
    thumb2 likes this.
  4. bertus

    Administrator

    Apr 5, 2008
    15,645
    2,344
    Hello,

    In the PDF reader you have some options.
    One of them will be shrink to fit, wich will change the size of the printed object.
    One of the other will be 100% orn something like that.

    Bertus

    PS one of the other options is "do not scale"
     
    Last edited: Dec 13, 2015
    thumb2 likes this.
  5. nerdegutta

    Moderator

    Dec 15, 2009
    2,515
    785
    I have the same printer, and I'm using Eagle. I never thought of printing to a PDF and then to the printer. I always print directly from Eagle. And, along with the comment from @spinnaker, I only mirror the top layer.
     
    thumb2 likes this.
  6. spinnaker

    AAC Fanatic!

    Oct 29, 2009
    4,866
    988
    I also print direct with Diptrace. But you need to remember to preview then print. Preview gives you more options.

    If I recall, ExpressPCB did not offer a mirror feature while the print to PDF driver I was using did. I would first need to print to PDF to get it to mirror. That could be the issue with the OP printing to PDF first.
     
    Last edited: Dec 13, 2015
  7. thumb2

    Thread Starter Member

    Oct 4, 2015
    66
    4
    :oops::oops::oops::oops::oops:

    You are right ! I had set the option Fit to printable area. :eek:
    Now I set it to NONE, and I will check it every time I will have to print. :rolleyes:

    Thank you guys.
     
  8. JohnInTX

    Moderator

    Jun 26, 2012
    2,341
    1,024
    An old trick to check scale is to place two lines (one in the X direction, one in Y) of known length outside of the board outline. Print the artwork then measure the length of the lines with a calipers or some other decent scale. Its easier to see small scale errors if the lines are as long as possible.
    When you submit the artwork to build the board, the CAD/CAM guys will remove the lines or you can delete and reprint with the same settings.
     
    thumb2 and spinnaker like this.
  9. spinnaker

    AAC Fanatic!

    Oct 29, 2009
    4,866
    988

    One of those things that is really obvious once some explains it. :)
     
Loading...