Problem with ECG amplifier

Discussion in 'The Projects Forum' started by teen devil, Oct 3, 2013.

  1. teen devil

    Thread Starter Active Member

    Apr 6, 2009
    47
    0
    Hi guys i am trying to build an ecg amplifier.. i am trying to build such amplifier which have
    Amplifier gain: 250, 500, 1000, 2000, 5000
    Bandwidth (-3dB): 0.05-500 Hz
    Notch filtering at 50 Hz (can be switched in or out)
    i am using
    intrumentation amplifier = AD620

    Op-amp = lm 741

    when i am using simple function generator i am getting good amplification and also i can vary the gain for e.g my input from F.G is 2mV(p-p) with freq of 10hz and at output i am getting 10V(p-p) i.e. gain of 5000

    but when i am trying to put a wav. file input of hearbeat with freq of 15khz its amplification is decreasing to gain 2000
    i am using multisim 11 to simulate this . i am posting the circuit pics also .. can someone tell me am i on the right track or my circuit needs any tweaking .
    will be waiting for your reply guys
     
  2. GopherT

    AAC Fanatic!

    Nov 23, 2012
    6,061
    3,826
    The Gain Bandwidth Product of the terrible, old 741 op amp is only 1,000,000. You are ok with 50 hz input, but at 15k hz, and gain of 2000, you are way over 1 million gain bandwidth product. Pick a more moder op amp.
     
  3. teen devil

    Thread Starter Active Member

    Apr 6, 2009
    47
    0
    i am thinking to use AD705 i've read it's much morre stable and compatible with AD620 instrumentation amp ..
     
  4. teen devil

    Thread Starter Active Member

    Apr 6, 2009
    47
    0
    or if u know any better one can u suggest me ??
     
  5. teen devil

    Thread Starter Active Member

    Apr 6, 2009
    47
    0
    i ran the simulations again like i did it before also implemented 50hx notch filter when i used 15khz heart beat audio the results are in the pics
     
Loading...