problem with 32" lcd tv

Discussion in 'General Electronics Chat' started by danbr, Mar 19, 2011.

  1. danbr

    Thread Starter New Member

    Mar 19, 2011
    2
    0
    Hi,

    I have a problem with a sanyo 32" lcd tv. The screen is black but there is sound. I have used a torch on the screen and can see that it is infact working just the lighting isnt working. I presume this would be the inverter board? I have attached an image below, have tested that 24v is coming into the board but nothing is going out to the outputs to the screen. Can someone confirm that this is correct and that this board just needs replacing?



    Cheers,
    Danny
     
  2. EdGs

    New Member

    Mar 10, 2011
    17
    2
    Sounds to me like it might be just that, but you can search the net with your model# and problem and you may find a site that that might have the solution for your exact problem, and maybe instructions and vids too.

    I have fixed a couple flat panel monitors this way. One had 2 bad capacitors - 59 cents for parts, and the other had 4 bad transistors on the inverter board - they cost about $4 for all. An hour later, they were up and running, and still are 5 years after the repairs.

    Good luck and post back if you get it sorted out.

    Ed
     
  3. danbr

    Thread Starter New Member

    Mar 19, 2011
    2
    0
    Thanks for your reply, i have ordered the board and will report back once i have fitted it.

    Danny
     
  4. debe

    Well-Known Member

    Sep 21, 2010
    947
    184
    Hi Danny, Where you measured 0V you are lucky the supply isnt working, otherwise your multi meter may have been wrecked as that plug looks like the feed to the backlight tubes. This is generaly HV AC not a lot of current but does burn (ive experienced this my self)
     
  5. R!f@@

    AAC Fanatic!

    Apr 2, 2009
    8,754
    760
    I have seen that board somewhere.
     
Loading...