Problem in PWM Isolation

Discussion in 'Analog & Mixed-Signal Design' started by chirag modesara, Jul 27, 2016.

  1. chirag modesara

    Thread Starter New Member

    Dec 23, 2015
    2
    0
    my project is isolator which can convert j type thermocouple in 2 channel.
    so here i using micocontroller and HCNR200 as a Isolation ic.
    but i cant got perfect reading from HNCR200 .
    My Pwm is correct.
    can anyone tell me where i made mistake.
    is that HCNR200 good for PWM isolation??
     
  2. Sensacell

    Well-Known Member

    Jun 19, 2012
    1,129
    266
    Without a schematic, your words are meaningless.

    Thermocouple and PWM in the same sentence?
     
  3. chirag modesara

    Thread Starter New Member

    Dec 23, 2015
    2
    0
    Thnks sensacell for fast responce,

    find the attached isolation schematic.

    i am using +5 and _5 instead of 15 and -15 respectivaly.
    and i also change the LT1097 opamp with OP07CP.

    microcontroller's Pwm out directly connected to this circuit. and i check the output at right side of this circuit.
     
  4. AlbertHall

    Well-Known Member

    Jun 4, 2014
    1,929
    381
    So the input to this circuit is PWM direct from a microcontroller - a 0V to 5V square wave?
    You say the output is not 'perfect' - what did you expect and what did you actually get?
     
  5. Sensacell

    Well-Known Member

    Jun 19, 2012
    1,129
    266
    Still have no idea what you are doing, that's just an application schematic from the data sheet.

    What are you trying to accomplish?
     
  6. DickCappels

    Moderator

    Aug 21, 2008
    2,651
    632
    Can you also help us find a datasheet for the HNCR200. I have a suspicion that it was not designed for high speed signalling.

    Related to that, what is your PWM clock frequency, the number of bits and the type of PWM waveform (comb or a single pulse per cycle)?
     
Loading...