Problem driving a relay

Discussion in 'The Projects Forum' started by gurupush, Mar 26, 2014.

  1. gurupush

    Thread Starter New Member

    Mar 21, 2014
    13
    0
    ok i will try to explain ,,my opamp inverting amp output is 4.7v normally..and when i put a load of 120gm on load cell the output switches to 5.4v...actually i wanted to drive a relay with its output but i think the current needed by the relay is more than that of the current given by 741........so i decided to use a lm311 as comparator....i gave output of the 741 to input of the lm311...and i prepared 5.1 as refernce voltage by means of a voltage didvider ckt using different battery suppy...but when i connect the 5.1 supply(from battery) to the refence of comparator for comparing then my input vltg(that i fed earlier i.e 4.7 from 741) rises automatically to 5.5 always above the reference vtg.....why this is happening can anyone help me on this?
     
  2. Dodgydave

    Distinguished Member

    Jun 22, 2012
    4,967
    744
    post your circuit please, so we can assist.
     
  3. wayneh

    Expert

    Sep 9, 2010
    12,087
    3,027
    With a comparator in the circuit, you probably don't need the op-amp. Maybe simplifying the circuit would help debug it.
     
  4. gurupush

    Thread Starter New Member

    Mar 21, 2014
    13
    0
    heres the ckt
     
  5. AnalogKid

    Distinguished Member

    Aug 1, 2013
    4,515
    1,246
    Pelase redraw your schematic to include the power and ground connections to the 741. And do you really have a 5.1V battery, or is the reference voltage coming from another circuit?

    ak
     
  6. wayneh

    Expert

    Sep 9, 2010
    12,087
    3,027
    It's worth pointing out that the comparator likely cannot drive your relay either. What are the details about that relay? How much current does it require at what voltage?
     
  7. gurupush

    Thread Starter New Member

    Mar 21, 2014
    13
    0
    i know that the comparator cannot drive the relay,,i will use trasistor for that but i want the comparator to change the 4.7v to 5.2v trasition to 0 to 12v ...so that i can use trasistor on off characteristic..but tell me when i connect refernce i get voltage rise of about 1v at 311 ip(means the 4.7 becomes 5.5)


    for 5.1 i am using voltage divider as mentioned earlier with seprate battery
     
  8. wayneh

    Expert

    Sep 9, 2010
    12,087
    3,027
    It's impossible to guess without a better schematic, and an understanding of how how you are measuring voltage. It's possible that the impedance of your meter is causing an artifact.

    For your transistor, consider a MOSFET. It will switch nicely with 12V on its gate, handle plenty of power, and it will not require a base current like a regular bjt.
     
  9. gurupush

    Thread Starter New Member

    Mar 21, 2014
    13
    0
    thank you for all the suggestions ,i will try with a MOSFET after debugging the circuit...
     
Loading...