Piezo Tranducer Sensor

Discussion in 'The Projects Forum' started by Teena123, Jan 31, 2013.

  1. Teena123

    Thread Starter Member

    Nov 22, 2012
    38
    0
    Guys i need help with my circuit, it isnt working this is the circuit i have. i cannot get an output when i hit the vibration sensor at pin 3(output) any help please?? I used a 2n7000 instead of BS170. What could be the problem please??
     
  2. Teena123

    Thread Starter Member

    Nov 22, 2012
    38
    0
    its to pick up engine vibration, the piezo transducer specifications are Piezo Transducer 27mm/4.2kHz
    Resonant frequency: 4.2kHz ±0.5kHz
    Impedance at resonance: 500Ω
    Capacitance: 14nF ±30%
    Maximum input voltage: 30V p-p
    Operating temperature: -20°C to +70°C.
     
  3. Audioguru

    New Member

    Dec 20, 2007
    9,411
    896
    Did you use a piezo transducer (speaker) or a piezo beeper that has an oscillator built in?
    It will not work with a beeper.
     
  4. Teena123

    Thread Starter Member

    Nov 22, 2012
    38
    0
    it is a piezo transducer (speaker).
     
  5. tracecom

    AAC Fanatic!

    Apr 16, 2010
    3,869
    1,393
    You know that the pinout on the BS170 is reversed from the 2N7000, right?
     
  6. Teena123

    Thread Starter Member

    Nov 22, 2012
    38
    0
    yes i did that but still not working??
     
  7. tracecom

    AAC Fanatic!

    Apr 16, 2010
    3,869
    1,393
    At this point, it is just a guess at what might be wrong. If you want more help, you have to provide more information.

    What are you trying to accomplish?
    You only provided part of the schematic; post it all.
    What have you tried and what have you found?
    What does the circuit do and what does it not do?
    What is your power supply?
    Is your assembly on a perfboard or a solderless breadboard?

    Post some closeup pictures of your assembly.
     
  8. Teena123

    Thread Starter Member

    Nov 22, 2012
    38
    0
    I'm trying to use it to measure the vibration from an engine, which when sensed i would like it to have a sound on a speaker at the pin 3 i dont wanna go beyond the circuit, it is a 9v to 0v voltage supply. but i dont even seem to get a signal at pin 3 when using a oscilloscope.
     
  9. Teena123

    Thread Starter Member

    Nov 22, 2012
    38
    0
    it is on a prefboard.
     
  10. tracecom

    AAC Fanatic!

    Apr 16, 2010
    3,869
    1,393
    There are people here who can help, but no one can guess what is wrong with your circuit without knowing what you have done. Until you provide pictures, all I can do is ask more questions.

    Why do you think you should be able to connect a speaker to pin 3 and hear anything? The 555 is not set up as an oscillator in this circuit.
     
  11. Audioguru

    New Member

    Dec 20, 2007
    9,411
    896
    The 555 is not an audio amplifier. It is a timer.
    The circuit you found will not do what you want and I don't think it will do anything.
     
  12. tracecom

    AAC Fanatic!

    Apr 16, 2010
    3,869
    1,393
    Here is a report on the complete circuit that you have posted only a part of. Even though the report is not very well written, maybe it will help.
     
  13. Audioguru

    New Member

    Dec 20, 2007
    9,411
    896
    I see.
    It is a car burglar alarm circuit.
    When I close the door of my car then the car beside my car makes a siren sound because it has this extremely simple circuit that detects the vibration caused by the door on my car closing. It makes many false alarms.
     
  14. tracecom

    AAC Fanatic!

    Apr 16, 2010
    3,869
    1,393
    Does the cover page of the report mean that this is a project done by three engineering students who are in their fourth year of college?

    And are earth "quacks" common in India?

    And is plagiarism rampant among engineers in India?
     
    Last edited: Feb 1, 2013
  15. Teena123

    Thread Starter Member

    Nov 22, 2012
    38
    0
    Okay i can get some signals at the moment but i need another help i want to display my output using leds, meaning low vibration will display green led while red to display green led any suggestion on circuits??
     
  16. tracecom

    AAC Fanatic!

    Apr 16, 2010
    3,869
    1,393
    My suggestion is for you to post a schematic of what you have built. Otherwise, there is no way for anyone to suggest anything sensible.
     
Loading...