PICKIT 2 not picking up 18f452

Discussion in 'Embedded Systems and Microcontrollers' started by roro36, Sep 8, 2010.

  1. roro36

    Thread Starter Member

    Sep 7, 2010
    52
    0
    I have connected my pickit 2 to my microcontroller as in the picture but every time I try reading or just make a connection, I get either no device detected or some parts are not auto detect. I had a 18f4550 and it worked fine, but all I could get this time was 18f452. Any ideas?
     
  2. t06afre

    AAC Fanatic!

    May 11, 2009
    5,939
    1,222
    I think you have connect the two VDD pins to the PICKIT 2, and the same will also apply to the VSS pins
     
    roro36 likes this.
  3. roro36

    Thread Starter Member

    Sep 7, 2010
    52
    0
    I Have tried that but still nothing..
     
  4. t06afre

    AAC Fanatic!

    May 11, 2009
    5,939
    1,222
    Just to be sure, you know the the PICKIT pin order from left to right is 6,5,4,3,2,1 . The white marker point to pin 1. Is your PIC in a circuit? Or are you programming your PIC outside the circuit
     
  5. LTX71CM

    New Member

    May 23, 2010
    8
    1
    Try pulling pin 38, LVP, low.

    And as t06afre asked it would be helpful to know if you're attempting this in-circuit or not. Other parts may be interfering with proper operation.
     
    roro36 likes this.
  6. t06afre

    AAC Fanatic!

    May 11, 2009
    5,939
    1,222
    Which tool do you use for programming? A thing to check is that your chip has power. The Pickit may support the chip with power during programming but this option has to turned on then
     
    roro36 likes this.
  7. roro36

    Thread Starter Member

    Sep 7, 2010
    52
    0
    Not sure what exactly happened but its working now. Perhaps one of the suggestions worked as I took the connections apart and tried again with the above solutions. Thanks for the help.
     
  8. bertus

    Administrator

    Apr 5, 2008
    15,645
    2,344
Loading...