PICAXE 08M2 Problem

Discussion in 'Embedded Systems and Microcontrollers' started by DRock, Aug 31, 2011.

  1. DRock

    Thread Starter Member

    May 7, 2011
    68
    0
    Hey everyone,

    I am attempting to tackle my first project with microcontrollers as a recently graduated mechanical engineer, so I really don't know too much about all this stuff YET. I have a breadboard with the PICAXE 08M2 and the stereo jack breadboard adapter from http://www.sparkfun.com/products/8331 and I cannot seem to get it to work.

    I am using the stereo to serial connector but my laptop does not have a serial port so I am using the Dynex serial to USB adapter and the Prolific PL-2303 drivers. I have already used this setup numerous times with my BASIC Stamp and it works just fine.

    I am using the AXE029 breadboard adapter instructions and the PICAXE Programming Editor but when I try to download my program it says: Serial Port Error Code 0x1F54 'Error Reading Comm Device'

    I am not sure where I am going wrong, I don't know if it is a software issue with the drivers I currently have installed or if it is a hardware issue perhaps due to incorrect connections or a sloppy solder joint.

    Do any of you have experience with this setup? I am hoping someone can help me out so that I can begin to test and debug my program.

    Thanks in advance for any help!
     
  2. DRock

    Thread Starter Member

    May 7, 2011
    68
    0
    I am attaching two pictures of my current setup, let me know if you guys spot anything wrong.
     
  3. DRock

    Thread Starter Member

    May 7, 2011
    68
    0
    Guess no one does it this way, where can I get a stereo jack that I can plug into the breadboard? I will just place the resistors on the breadboard and call it a day.
     
  4. upand_at_them

    Active Member

    May 15, 2010
    246
    29
    Could be an issue with the virtual serial port.
     
Loading...