PIC operation failed

Discussion in 'Embedded Systems and Microcontrollers' started by jurinov, Jul 4, 2016.

  1. jurinov

    Thread Starter New Member

    Nov 17, 2015
    3
    1
    I use a PICkit 3 and a PIC32 MX795F 512L, but the device wasn't detected. I have tried PIC18F4520 and it was working well.
    I selected manually the right device and tried to import and write hex file, but the reaction was: "operation failed". The PIC32 device family can't be recognised at all.

    Could you help me please what can be the problem?
     
  2. NorthGuy

    Active Member

    Jun 28, 2014
    603
    121
    PICkit3 is hardware. What software do you use? If it lets you select PIC32MX795F512L then apparently it knows that such device exists. I would suspect the connection.
     
  3. jurinov

    Thread Starter New Member

    Nov 17, 2015
    3
    1
    Hi, I'm using PICkit 3 (tried more than one versions), and also MPlab IDE (8.92) also.
    I did the wiring according to this schematic, although i emmitted the parts I did not circle, and used some other values.
    13624528_1237395629634556_1083597141_n.jpg
     
  4. Picbuster

    Member

    Dec 2, 2013
    373
    50
    Hi, what is your power source; pic kit or its own supply?
    All , at the first glance looks right.
    Picbuster
     
  5. jurinov

    Thread Starter New Member

    Nov 17, 2015
    3
    1
    Hi! thanx for the reply guys it started to work, after i did some soldering, (the source was from my pc 3.3v), probably my breadboard gave up, but now it works like a charm :)
     
    atferrari likes this.
  6. NorthGuy

    Active Member

    Jun 28, 2014
    603
    121
    Congratulations!
     
Loading...