Oscillator Simulation Help

Discussion in 'Homework Help' started by crazyengineer, May 3, 2011.

  1. crazyengineer

    Thread Starter Member

    Dec 29, 2010
    156
    2
    Hello Everyone,

    I'm trying to test a simple Wien bridge oscillator, but my simulation is not producing the waveform. Can anyone help me? Here's a pic of the simulation
     
  2. Jony130

    AAC Fanatic!

    Feb 17, 2009
    3,962
    1,097
    Use Initial conditions marker.
    Or use additional current source ISRC
    Tran = PWL(0US 0MA 1US 0.1MA 4US 0.1MA 5US 0MA 10MS 0MA)
     
    • 1.PNG
      1.PNG
      File size:
      9.3 KB
      Views:
      14
    • 2.PNG
      2.PNG
      File size:
      22.4 KB
      Views:
      19
  3. crazyengineer

    Thread Starter Member

    Dec 29, 2010
    156
    2
    where can I find them in or cad? Also, where should I place them?
     
  4. crazyengineer

    Thread Starter Member

    Dec 29, 2010
    156
    2
    Also when I did this, I got a weird graph
     
  5. Jony130

    AAC Fanatic!

    Feb 17, 2009
    3,962
    1,097
    Well your circuit don't have any Automatic gain control.
    And this s why opamp is in saturation.
    So you need AGC circuit. (Look at my diagram)
    And cur set R=51K and C=100pF so the output Frequency we be equal to
    Fo = 0.16/RC = 31.4KHz
    So need to change Run to time from 1s to 200us
     
  6. Audioguru

    New Member

    Dec 20, 2007
    9,411
    896
    A lousy old 741 opamp is 43 years old. Its gain at 31.5kHz is only about 20 and its max output level is only about plus and minus 5V.

    The resistors in your circuit are both the same value but its capacitors are not so it doesn't oscillate.
     
Loading...