Optocoupler combined with gate driver. cannot get output!

Discussion in 'The Projects Forum' started by hidayah15, Mar 28, 2016.

  1. hidayah15

    Thread Starter New Member

    Mar 13, 2016
    6
    0
    im doing a final year project.
    im using optocoupler 6n137 and gate driver fan7382
    it works okay on its own however when i connect the output of the optocoupler to my input fan7382, it does not give any output at the high out and low out. any advices??

    6n137.jpg fan7382.jpg
     
  2. MrChips

    Moderator

    Oct 2, 2009
    12,449
    3,365
    Verify the lead diagram of the 2N2222 transistor. There are two different pin-outs.
     
    hidayah15 likes this.
  3. Alec_t

    AAC Fanatic!

    Sep 17, 2013
    5,813
    1,105
    What voltages are you seeing at input pins 2 and 3 of the 7382?
     
    hidayah15 likes this.
  4. hidayah15

    Thread Starter New Member

    Mar 13, 2016
    6
    0
    what do u mean verify the
    2n2222.png
    im using muticomp 2n2222 transistor. the input to my gate driver fan7382 is from the collector of the transistor
     
  5. hidayah15

    Thread Starter New Member

    Mar 13, 2016
    6
    0
    output from collector transistor.jpg
    the yellow waveform is the input at the optocoupler
    the blue waveform is the waveform at the transistor collector. i connected the collector output to the pin 2 and pin 3 separately to get the separate waveform for the lowout and highout. below are the 2 waveforms.
    output lowout at driver side.jpg
    the blue waveform output lowout at driver side
    output highout from driver side.jpg
    the blue waveform is the output highout from the driver side
     
  6. Alec_t

    AAC Fanatic!

    Sep 17, 2013
    5,813
    1,105
    What voltage do you get at pin 6 of the 6N137?
    Is pin 5 of the 6N137 properly grounded?
    Try increasing RL to at least 1kΩ.
     
  7. hidayah15

    Thread Starter New Member

    Mar 13, 2016
    6
    0
    i am able to obtained the output. its due to the grounding error.
    thankyou for your inputs! much appreciated! :)
     
  8. Alec_t

    AAC Fanatic!

    Sep 17, 2013
    5,813
    1,105
    Good to know you've got it working.
     
Loading...