Need some help with Arduino-microcontroller.!!

Discussion in 'Embedded Systems and Microcontrollers' started by Sonoma_Dog, Sep 26, 2008.

  1. Sonoma_Dog

    Thread Starter Active Member

    Jul 24, 2008
    99
    0
    all right, i have been scratching my head for the whole morning and still can not figure out what the hack is going on.

    All right, so i just wanted to use this micro-controller to control the a MOSFET to drive some LEDs and make them blink, sounds easy enough huh?

    Here is my schematic, V1 is a PWM that come from the microcontroller.

    ok here is the problem I have, This schematic will only works on pin 13 of the Arduino-microntroller (the one with a 1kohm attached to it). For all other pins, I got this symptom.
    Lets Use pin 12 for example.

    1) I have set pin 12 pull HIGH all the time (constantly 5 volt)
    2) when pin 12 is not connecting to anything, the DMM reads 5 volt
    3) when pin 12 connected to the gate chanel of the MOSFET, it reads 1.5volt, MOSFET Is not turned on. it also only draw less the 0.01mA, as it would normally draw about .3mA on a 5 volt terminal.

    Does anyone have the schematic of the Arduino-microcontroller?

    I am also runing out of hair :eek:

    Thanks!!
     
    • 12.JPG
      12.JPG
      File size:
      74.5 KB
      Views:
      13
  2. hgmjr

    Moderator

    Jan 28, 2005
    9,030
    214
    Are you certain that you have set the pin in question as an output pin?

    hgmjr
     
  3. Sonoma_Dog

    Thread Starter Active Member

    Jul 24, 2008
    99
    0
    Oh wow...................................................problem solved.....................

    why am i so stupid......
     
  4. hgmjr

    Moderator

    Jan 28, 2005
    9,030
    214
    One thing about microcontrollers is there is a lot of housekeeping that must be taken care of for all to go smooth.

    hgmjr
     
Loading...