Need help with willem eprom pcb 5.0E

Discussion in 'General Electronics Chat' started by need help, Feb 13, 2013.

  1. need help

    Thread Starter New Member

    Jan 11, 2011
    6
    0
    No sure if I put this in the right place or not. Here goes nothing. I recently obtained a willem eprom programmer pcb5.0e. currently running Willem Eprom PCB5.0C (0.98D8) software. My question is do I need drivers for this programmer and is this the right software to run this programmer. When I got it, it didn't come with the software and if their was a driver didn't get it. The software I got off the internet and really not sure if its the right one. Installed the software and when I try to connect the programmer to it. I get an error message "Hardware error: check power and connections." Checked all of that and it seems like the everything is plugged in right. When I power the programmer up a green light comes on where is says power, but can't seem to connect the device. Am I missing something. Is there other lights that come on when it powers up. If I got the wrong softer and need drivers can somebody help me obtain them or send me a link to download them. I included a pic of the programmer I have too.

    Thanks in advance
     
  2. SPQR

    Member

    Nov 4, 2011
    379
    48
    I went to the SIVAVA website, and it seems that there is a driver necessary.
    I can't load the .pdf that explains it though.
     
  3. need help

    Thread Starter New Member

    Jan 11, 2011
    6
    0
    By any chance can you pm me the link. I was on there, but can only find window 7 and not sure if that's the drive for window xp. Also if you found the manual can you pm the link to that too.

    Thanks
     
  4. SPQR

    Member

    Nov 4, 2011
    379
    48
    http://www.sivava.com/download.html

    I can't PM you, you've turned off your PM.
     
  5. need help

    Thread Starter New Member

    Jan 11, 2011
    6
    0
    Thanks for the website, but I can't seem to download the first one on the list. And all the other ones are not for the pcb5.0e. They are only for earlier models. Is there some way around it.

    Some questions. The DLPortIO only for window 95/98 and nt. For I am running win XP. I can't seem to download it from the website you provided. I also need to know how to install the software for xp. The 0.97Jb software is that what I need to use with this programmer for it is a pcb5.0E or at least I think it is. The other ones on list does not list my programmer so i'm guessing its not the right software. Really didn't realize this was going to be this hard to install the software.LOL



    thanks
     
    Last edited: Feb 14, 2013
  6. SPQR

    Member

    Nov 4, 2011
    379
    48
    Let start with the easy stuff.

    Where did you buy it?
     
  7. need help

    Thread Starter New Member

    Jan 11, 2011
    6
    0
    I got it online on another forum. They Said it worked, but didn't come with cables, manual or disk, but told I could find it on the internet. So, I didn't worry about. Then moved forgot all about until the other day when I was looking for something. And happened to come across it again. So that's where I am at now. really not sure how to hook it Jup. Meaning do use just USB or printer cable. Or do I use both. I hooked up just the USB and the green light came and stay one. Then I just hooked up the printer cable and the green comes on, but it's not as bright. Then plugged in both and the green light comes on. There was a read light that came on beside the green light. It was at the far right side light. So, I just assumed everything was working when I seen the green light. I did notice when I hook up the USB the computer does find the device like when I hook up other USB devices. It's almost like the programmer isnt being recognized buy the computer. I do have a bk programmer hooked to the computer to. But I disconnected it though. I didn't know if the computer is having conflicts between the two. Just a thought.

    Thank in advance
     
  8. SPQR

    Member

    Nov 4, 2011
    379
    48
  9. need help

    Thread Starter New Member

    Jan 11, 2011
    6
    0

    I got a power supply. it was 9v. but it still don't seem to be working 100%. Do you know what size power supply is ideal to be able to run all the eproms it can handle. I know I wont use them all, but would like to get a power supply that will handle them all though. On the board is said 9v to 12v and I got a 9v. Which isnt working.

    With the 9v ps Got it to finally pick up the device. thought is was reading the eprom, but when I take it into hexedit. it just shows up with a bunch of this repeating itself.
    04 04 04 04 04 04 04 04 04 04 04 04 04 04 04 04 04 04 04 04 04 06 04 04 04 04 04 04 04 06 04 06 04 04 04 04 04 04 04 04 04 04 04 04 04 04 04 04 04 04 04 04 04 06 04 06 04 06 04 06 04 06 04 06 04 04 04 04 04 04 04 04 04 04 04 04 04 04 04 04 04 04 04 04 04 06 04 06 04 04 04 06 04 06 04 06 04 04 04 04 04 04 04 04 04 04 04 04 04 04 04 06 04 04 04 06 04 06 04 06 04 06 04 06 04 06 06 06 04 04 04 04 04 04 04 04 04 04 04 04 04 04 04 04 04 06 04 06 04 06 04 06 04 06 04 06 04 06 04 06 04 04 04 04 04 04 04 04 04 04 04 04 04 06 04 06 04 06 04 06 04 06 06 06 04 06 04 06 06 06 06 06 04 04 04 04 04 04 04 04 04 04 04 04 04 04 04 06 04 06 04 06 04 06 04 06 04 06 04 06 04 06 06 06 04 04 04 04 04 06 04 06 04 04 04 06 04 06 04 06 04 06 04 06 04 06 06 06 04 06 06 06 06 06 06 06 14 14 14 14 14 14 14 14 14 14 14 14 14 14 14 14 14 14 14 14 14 14 14 14 14 14 14 14 14 16 14 16 14 14 14 14 14 14 14 14 14 14 14 14 14 14 14 14 14 14 14 14 14 16 14 16 14 16 14 16 14 16 14 16 14 14 14 14 14 14 14 14 14 14 14 14 14 14 14 14 14 14 14 14 14 16 14 16 14 14 14 16 14 16 14 16 14 14 14 14 14 14 14 14 14 14 14 14 14 14 14 16 14 16 14 16 14 16 14 16 14 16 14 16 14 16 16 16 14 14 14 14 14 14 14 14 14 14 14 14 14 14 14 14.

    So Im guessing it not a big enough ps. I was checking a tms27c128. and it shows the same thing with am27c64 and tms27c512.

    any help would be greatly appreciated.


    thanks
     
  10. akuma6099

    New Member

    Mar 21, 2013
    1
    0
    I bought this programmer about a year ago while working on some Tivos. It works quite well. Now the only guy that actually makes the 5.0E is Kee Electronics. The REAL/Official willem programmer is made by sivava. Thier latest version is 5.0B. The software that Kee Electronics sends on CD is version 98D12C. This is what you use for 5.0E. On the bottom left of the willem you should see 2 jumpers to set your version. If you set it to 3B mode, then you should use software version 97JA. Also if you run into bytes changing and you can't get a good dump, then turn up tWP and tWC a couple clicks. This usually smooths things out. Sometimes the programmer is reading faster than the bytes arrive. If you miss a bit or 2 your whole image is corrupt. I do admit the documentation is scarce. I think you will find everything you need on Kee Electronics site. The downloads are a little burried.

    You will Always hook up the LPT cable. This is required. The USB is only used for VCC of your target chip. There is a jumper in the bottom right to set USB_VCC or External_Supply which can be a 9V/12V DC wallwart. NEVER PLUG IN BOTH. Pick only 1 otherwise pop. USB is limited to 500ma so I typically use a wallwart. Other than that, pay attention to the silk screen for help on the other jumper packs like j7, j6 in the upper right. They are slightly seperated and the silk screen helper shows them side by side. No biggie, easy to interpret. Once in awhile you might have to jump pins A19+A21 in the lower left. The Diagrams should show this if required after selecting your target chip.
     
    Last edited: Mar 21, 2013
Loading...