Need help with this schematic

Discussion in 'General Electronics Chat' started by dick56, Oct 22, 2014.

  1. dick56

    Thread Starter New Member

    Apr 27, 2011
    23
    3
    Attached is a schematic for a power supply. On the far right had side is a ground symbol which appears to be connected to the 2N3055 emitters (through the 82 ohm resistors), but that line is supposed to have the output to P3. M1 and I1 and M2 and I2 are the outputs to the analog to digital converter readouts. The 2n3055 transistors fried and the 82 ohm ceramic wire wound resistors fried, and I have replaced these components, but I am not getting any output voltage at x2 and x4. Can someone explain the ground symbol on the far right side? Thank you.
     
  2. MikeML

    AAC Fanatic!

    Oct 2, 2009
    5,450
    1,066
    The four-bar ground symbols scattered around this schematic is just short-hand for "tie all of these together with a low-impedance fat wire or copper trace". That becomes one electrical node in the circuit; connected to output terminal "X2". If you use an Ohmmeter to measure continuity from there to the chassis or output terminal X3, you should read an open; they are two different nodes...

    Have you checked R15a for continuity?
     
  3. MaxHeadRoom

    Expert

    Jul 18, 2013
    10,509
    2,369
    It does not help that they have the chassis common and earth ground symbols completely mixed up (misused) and documented wrong!
    Max.
     
  4. BillB3857

    Senior Member

    Feb 28, 2009
    2,400
    348
    I think the 82 ohm resistors you are referring to are 0.82 ohm for current balancing between the 3055 transistors. If you replaced them with 82 ohm resistors, you will have a problem.
     
  5. cmartinez

    AAC Fanatic!

    Jan 17, 2007
    3,555
    2,517
    Bill's right... if you installed 82Ω resistors instead of the 0.82Ω indicated in the diagram, then the arrangement would work more as a voltage divider instead of a current balancer, and things could possibly go haywire from there...
     
  6. dick56

    Thread Starter New Member

    Apr 27, 2011
    23
    3
    Bill, thanks for the heads up on the 0.82 ohm resistors. I will check to see what I soldered in there.
     
  7. dick56

    Thread Starter New Member

    Apr 27, 2011
    23
    3
    Bill, you were right on. They were0.82 ohm resistors. I got some from Mouser and soldered them in and the power supply is working. One thing I noticed is when in the Constant Current mode, the voltage increases when you increase the output current. It didn't do that before so it appears the voltage limiting circuit is not working correctly. I don't know how to tell where the voltage limiting circuit is in the schematic in post #1. Dose anyone have an ides where the limiting circuit is?
     
  8. wayneh

    Expert

    Sep 9, 2010
    12,093
    3,032
    And what did you expect? Consider ohm's law. How can you drive more current thru a resistor without increasing the voltage across it?
     
  9. BillB3857

    Senior Member

    Feb 28, 2009
    2,400
    348
    If you use the constant voltage mode, does the voltage stay constant when you change the load resistance. If so, it is working just right.
     
  10. kubeek

    AAC Fanatic!

    Sep 20, 2005
    4,670
    804
    In constatnt current mode the voltage should rise, but only up to the point set by the voltage control.
     
  11. dick56

    Thread Starter New Member

    Apr 27, 2011
    23
    3
    BillB, no the voltage changes when more load is applied when in the constant voltage mode. I am thinking the one section of the 741 op amp is not functioning correctly.
     
  12. dick56

    Thread Starter New Member

    Apr 27, 2011
    23
    3
    kubeek, that is the way it worked before, but if I set 14 volts and then increase the current to say 2 amps from 1.5 amps, the voltage rises above the 14 volts set on the voltage side immediately. The way I charge small aircraft batteries with this charger (when it works) is to set 2 amps and the voltage will read whatever is in the battery. As the battery charges, the voltage rises up to around 15.8 (the current stays at 2 aamps) when the battery is charged and all six cells are equalized to around the same specific gravity. I have never charged car batteries, but I would assume they respond the same way. Actually I just found out that someone was trying to charge my car battery when I was away and fried the charger in the process. It is possible the damage came from cross connecting the leads as this charger does not have good cross connection protection.
     
  13. BillB3857

    Senior Member

    Feb 28, 2009
    2,400
    348
    If you set the current control to MAX and set the voltage control to mid range, it should hold constant voltage with a variable load as long as the load doesn't try to pull more current than the max current setting.

    Do you have the user manual for your unit? What about a service/calibration manual?
     
  14. dick56

    Thread Starter New Member

    Apr 27, 2011
    23
    3
    BillB, no I do not have a service manual. This is an Asian unit and all I could get out of them was the schematic which is why I am searching for a possible clue to the problem. I appreciate all the help from the forum.
     
  15. BillB3857

    Senior Member

    Feb 28, 2009
    2,400
    348
    The way I see it, N2 is the sense amplifier for current control and N1 is the sense amplifier for voltage control. N2 (current control) is comparing the wiper voltage of W6 with the emitter voltage of the 3055 bank. These use the 2.5V reference supplied by V5A. As long as the voltage on N2 pin 2 is less than that on Pin 3, V9 will be reverse biased by a positive voltage on pin 6 and no foldback and no OL indication. It took me a while to figure out how the voltage channel sense was being accomplished, then I realized that the line feeding X4 is actually the negative output so W7 pot is the sense element. As long as the voltage on the wiper of W6 is more negative than 0v, no voltage foldback. R16, W6A, W5 and W7 make up a voltage divider between +2.5v and the output. It looks like V17A and V18A monitor the output voltage and if it goes to near zero, forces the current limit circuit to become active.

    As to your problem, I looks like it will need a lot of measuring and variable loads being available to iron it out.
     
  16. dick56

    Thread Starter New Member

    Apr 27, 2011
    23
    3
    BillB, many thanks for the circuit description. With what you wrote, I should be able to wring out the problem. Thanks again, I will post what I find. Dick
     
Loading...