Need help with converting 0-5v signal to 0-10v signal

Discussion in 'The Projects Forum' started by François TEYSSERE, Jun 15, 2015.

  1. François TEYSSERE

    Thread Starter New Member

    Jun 15, 2015
    3
    0
    <Moderator's note: You had hijacked a stale thread, here is a fresh thread of your own>

    ,

    I'm trying to make exactly the same circuit than OP, to get from a 0-5V voltage to a 0-10V. I'm using the LCM6081 op amp as well, and did the same circuit you did in the first post. The only difference is that I'm feeding the op amp with a 12V battery.

    The circuit kind of works but it seems that it is saturated to around 5V, because the voltage is effectively multiplied by 2 until I put more than 2.5V on Ve, at which point it keeps giving me a 5V output... Does any of you have an idea of where it could come from?
     
    Last edited by a moderator: Jun 15, 2015
  2. François TEYSSERE

    Thread Starter New Member

    Jun 15, 2015
    3
    0
    Nevermind, got it to work
     
  3. djsfantasi

    AAC Fanatic!

    Apr 11, 2010
    2,810
    834
    @François TEYSSERE - Can you post the solution to your problem, for members in the future who are experiencing the issue as well?
     
  4. François TEYSSERE

    Thread Starter New Member

    Jun 15, 2015
    3
    0
    Well it wasn't an actual issue, the device with which I was measuring the output voltage couldn't handle more than 5V so it just said 5V. When I then tried to measure with a classical multimeter I realized I actually had the desired voltage. The previous post could even be deleted given the simplicity of the problem.
     
  5. djsfantasi

    AAC Fanatic!

    Apr 11, 2010
    2,810
    834
    Thank you. It's all valuable. I have a thread discussing how to troubleshoot a problem with audio to digital conversion. Turned out I forgot to set the volume!
     
Loading...