Need Help - My UPS and Battery

Discussion in 'General Electronics Chat' started by SarahKhan, Sep 27, 2010.

  1. SarahKhan

    Thread Starter New Member

    Sep 27, 2010
    1
    0
    Dear Friends

    Found this site while searching solution for my problem.

    I've an imported UPS and a heavy battery. They were working great till sometime back. What happens is that for some reason my UPS works with all other batteries and Battery works superb with all other UPS. However, when I try to run my UPS on my battery it does not work at all. Really confusing as both the equipments are in excellent condition and they have worked great together for last 7 or 8 months.

    I have no idea why is this happening, is there a technical fault or anything. None of the shopkeepers are able to understand this problem, they only insist on selling their items.

    If any of you can give some idea on what is happening or any solutions, I would deeply appreciate.

    Many thanks.
     
  2. pnjbtr

    New Member

    Nov 8, 2010
    1
    0
    It is no good to keep battery empty(without charge).
    If you will not charge a battery for long time,sulphation may occur on battery plates.
    Sulphated battery does not charge fully.
    It produce heat during charge.
    And lessen backup time.(in inverter mode).
    would you specify which battery,you are using.
    Is this wet automotive(almost use in vehicles) or dry?
     
  3. R!f@@

    AAC Fanatic!

    Apr 2, 2009
    8,747
    759
    Hi..Welcome

    What u have is rather strange fault.
    For u to rectify it. U shud know how to measure DC voltages using a DMM.

    If not, there is nothing much I can tell u what to do.
    May be it might help if u post some pictures of ur UPS and battery
     
Loading...