need help in h bridge -pwm

Discussion in 'Embedded Systems and Microcontrollers' started by ahmedkoyi, Feb 13, 2011.

  1. ahmedkoyi

    Thread Starter New Member

    Feb 13, 2011
    3
    0
    Hi every body>>> i am newbie here guys i need your help in H-bridge circuit
    i have 35 volt dc motor and also i can drive it with less that 35 volt, i want to drive it FW and BACKWARD by H-bridge cct >>> i connected the cct below
    [​IMG]
    with out diodes and with resistors 33 ohm value >>> the transistor i used is tip41c< i used this type only for the connection , i have a DAQ3001 (data acquisition personal 3001) device that used for experiments and taking measurements from sensors and driving actuators, but my question is when i connect the bases of the transistors i can not drive the motor.
    i measured the output of the Daq device its about 3.95 volts dc , so i dont know where is the problem please help me>>
     
    Last edited: Feb 13, 2011
  2. be80be

    Senior Member

    Jul 5, 2008
    432
    57
    Your H-bridge is a little wrong
     
  3. ahmedkoyi

    Thread Starter New Member

    Feb 13, 2011
    3
    0
    thanks for your answer..
    i think i didnt use pnp transistor
    and the diodes>>>
    is the lower base is always 5 volt (high)?
    is the pwm is applied to the upper base?
    thnks
     
  4. ahmedkoyi

    Thread Starter New Member

    Feb 13, 2011
    3
    0
    hey guys >> please answer me
     
  5. be80be

    Senior Member

    Jul 5, 2008
    432
    57
    What part? Read the sch I posted it tells how it works
     
Loading...