MOSFET problem don't turn off rising voltage

Discussion in 'Embedded Systems and Microcontrollers' started by EstebanF, Jul 20, 2009.

  1. EstebanF

    Thread Starter New Member

    Jul 20, 2009
    3
    0
    I have a problem
    the original circuit work @9v when rising the voltage don't turn off
    I try up the voltage to 16-18v (to get more power in solenoid)
    I search in your good forum but I don't get the solution
    [​IMG]
    http://bb.bbboy.net/straferbbmachinegunownersgroup-viewthread?forum=10&thread=2054

    the R6 (down left) is R8
    J1 is the ouput for the magazine have DC engine 9v .4A (and I like to down this voltage to 9V (original voltage)

    the IRLZ44 and U3 (like Bss295) don't turn off, I try reducing the R1 to 10K and have the same situation
     
  2. Tahmid

    Active Member

    Jul 2, 2008
    344
    25
    Alberto,
    Wouldn't 1k be a little too much?
    As R1, I would use 2.2k and place a gate resistor of 10ohm between uC port and MOSFET gate.
     
  3. EstebanF

    Thread Starter New Member

    Jul 20, 2009
    3
    0
    I have here 10kΩ and 20Ω resistors I will try and test
    if works I will tell you if not I will go for 2.2k and 1k for more test

    many thanks for this help
     
  4. EstebanF

    Thread Starter New Member

    Jul 20, 2009
    3
    0
    all works¡¡¡ :)

    Many thanks

    BTW to down the voltage @9v only in J1 output I try with zener and LM7809 and don't work
    the J1 energize a DC motor 0.4A
    I add one resistor 40ohm and work fine at 10v but when the motor have load the voltage down to 9 and some times the motor stop 0
     
Loading...