Monitors for LiFePO4

Discussion in 'The Projects Forum' started by Crazywizard, Jun 21, 2016.

  1. Crazywizard

    Thread Starter New Member

    Jan 21, 2015
    11
    1
    Hello,
    I am trying to wire 5 charge/discharge monitors onto a 12 volt 260Ah LiFePO4 battery that is made up of 4 x 3.2 volt Winston cells in series.
    I have a wire connected to each neg and pos terminals on the cells. These cells are connected in series via a copper strap from neg on #1 cell
    to pos on #2 cell etc. The idea is for a charge monitor on each cell that will activate a relay to stop any charging source when (if) that cell reaches
    a certain voltage. The 5th monitor measures the voltage of the whole pack. Hope that makes sense! Anyway, monitor on cell #1 and #4 work as
    they should. Monitors on the other 2 cells will not work. These monitors each receive 12 volt positive from the pack as well as neg and positive from the cell being measured. When I measure the voltage at the monitor the neg wire reads as a pos and the 12 volt pos as a neg. I am getting "back feed"
    or similar. Is there some way around this problem using a diode or something like that?
    Your help would be most appreciated by this novice.
    Thanks
    Les
     
  2. RichardO

    Well-Known Member

    May 4, 2013
    1,238
    385
  3. Crazywizard

    Thread Starter New Member

    Jan 21, 2015
    11
    1
    Many thanks RichardO,
    Those links were a big help. I now have it sorted and working.
    Regards,
    Les
     
Loading...