ltspice zvs simulation

Discussion in 'General Electronics Chat' started by bug13, Jun 14, 2014.

  1. bug13

    Thread Starter Well-Known Member

    Feb 13, 2012
    1,208
    38
    Hi guys

    I tried to simulate a zvs driver circuit, but I don't get anything out, how can I make it work?

    Vcc = 24V

    [​IMG]
     
    • zvs.asc
      File size:
      3.4 KB
      Views:
      79
  2. Alec_t

    AAC Fanatic!

    Sep 17, 2013
    5,800
    1,103
    Isn't U3 upside down?

    Edit:
    Skip the initial operating point solution.
    Set the sim time for 10ms or so, you get a more interesting result :).
     
    Last edited: Jun 14, 2014
    bug13 likes this.
  3. wakibaki

    New Member

    Jun 12, 2012
    7
    0
    All my LTSpice sims use a voltage source connected across Vcc and Ground. Perhaps you're using a feature I'm not familiar with?

    w
     
  4. crutschow

    Expert

    Mar 14, 2008
    13,014
    3,234
    You need to post the complete circuit including the driver and the voltage sources.

    You circuit has no connection between the driver source and the MOSFET inputs.

    The MOSFET gates need to be driven by the out of phase signals from transformer K1 (not shown).

    K1 must be driven from a bipolar signal (or the input capacitively coupled) to avoid core saturation.
     
    bug13 likes this.
  5. bug13

    Thread Starter Well-Known Member

    Feb 13, 2012
    1,208
    38
    Thanks, this fixed my simulation.
     
  6. bug13

    Thread Starter Well-Known Member

    Feb 13, 2012
    1,208
    38
    My K1 is for another simulation, I just have a bad habit of have two different simulation on the same file.

    But thanks for pointing that out, I will try that.
     
Loading...