LTspice error: Timestep too small

Discussion in 'The Projects Forum' started by mkssnwbrd, Apr 16, 2012.

  1. mkssnwbrd

    Thread Starter New Member

    Apr 16, 2012
    1
    0
    I am trying to simulate a circuit that will hopefully tell me if two input frequencies are different by giving a high or low output. I am still rather new to LTspice, I know a bit more using winspice, but don't have any flipflop or ligic models easily ready to use in winspice. I built it and simulated it but get the error:

    Time step too small; time = 0.00113801, timestep = 1.35285e-018; trouble with dflop-instance a3

    I have checked the forums, tried a few ideas I found, but can't get it to run longer than 1.2ms.

    LTspice net list:

    * C:\Users\Mike\WSU\Spring2012\EE415\FlipFlopFreqDetect.asc
    A1 N002 0 N001 0 0 N002 N005 0 DFLOP
    A2 N011 0 N014 0 0 N011 N012 0 DFLOP
    A3 N003 0 N001 0 N009 N006 N004 0 DFLOP
    A4 N003 0 N014 N004 0 N009 N013 0 DFLOP
    V3 N001 0 SINE(0 3.3 900 0)
    V4 N014 0 SINE(0 3.3 600 0)
    A6 N006 0 0 0 N010 N008 N007 0 AND
    A7 N003 0 0 0 N013 N010 0 0 AND
    A5 N005 0 0 0 N012 N003 0 0 XOR
    .tran 0 1 0 startup
    .backanno
    .end

    LTspice file is attached (if i did it right)

    Please help, need to figure out something for my senior project asap.
     
  2. Papabravo

    Expert

    Feb 24, 2006
    10,144
    1,790
    Do you have a GROUND Node?
     
  3. atferrari

    AAC Fanatic!

    Jan 6, 2004
    2,648
    764
    It seems there is ground in the schematic but not sure if properly connected to the circuit.
     
  4. Ron H

    AAC Fanatic!

    Apr 14, 2005
    7,050
    657
    I can't get past the timestep too small error either. Why don't you try it with CD4000 parts?
    BTW, did you change the symbol names of AND and XOR? I had to edit your .asc file in Notepad to get rid of the "2port" stuff added to the names.
     
  5. Ron H

    AAC Fanatic!

    Apr 14, 2005
    7,050
    657
    OK, I just remembered what you have to do. The problem is that rise and fall and delay times all default to zero.
    Try this version. You can turn off the parameter visibility. Right-click on the symbol to edit parameters.
     
Loading...