Logic probe registering Low when disconnected

Discussion in 'Homework Help' started by Mike C, Feb 11, 2015.

  1. Mike C

    Thread Starter New Member

    Feb 11, 2015
    6
    0
    So in this lab book I am using it has us build a logic probe which it claims will have both of the lights off if the probe is not connected. However when I test it the low light turns on when the probe is off.

    After some investigation I discovered my 7404 chip switches right at 2V.

    In the schematic they have a 2k resistor followed by 2 diodes followed by another 330 resistor. The diodes each seem to have a voltage drop of .7V which leaves 3.6V going through out of the 5V supply. Now at 3.6V this gives me a current of about 1.545 mA so the voltage drop across the 2k resistor would be 3.09 which gives me about 1.9V left after the 2k resistor which the 7404 is interpreting as a low and inverting.

    Am I doing something wrong here or is this just a bad example in the book?

    I am thinking if I throw an extra diode in to drop the voltage another .7V it would fix it.

    I've attached the 2 pages from the lab manual.

    Thoughts?
     
    • lab2.pdf
      File size:
      295.7 KB
      Views:
      23
  2. WBahn

    Moderator

    Mar 31, 2012
    17,757
    4,800
    I can't tell without seeing what they had to say on Page 13, but it appears that whoever wrote that doesn't understand the concept of logic thresholds very well.

    The 2.0V limit is the lowest level that a TTL input can see and be guaranteed to recognize it as a logic HI. It might well recognize voltages considerably below that as a HI. Similarly, 0.8V is the highest level that a TTL input can see and be guaranteed to recognize it as a logic LO. It might well recognize voltages considerably below above that as a LO. A voltage between 0.8V and 2.0V will almost certainly be recognized as one or the other (the actual active region is very narrow), you just don't know which.

    To ensure that both lights are off when the probe is disconnected, the upper input must be above 2.0V and the lower input must be below 0.8V.

    Also, it doesn't look like they took into account the Vout range of TTL logic or the very limited drive strength of an output that is HI.

    In order for this probe to see a logic HI, the signal driving the probe must get the input of the bottom inverter up to at least 2V. This means that the voltage at the probe tip must be at least 2.7V while supplying 6mA. Well, the Vohmin for 74xx is 2.4V at 400uA and even for 74LSxx it is 2.7V at 1mA.

    Similarly, in order for this logic probe to see a logic LO, the signal driving the probe must get the input of the top inverter down to at least 0.8V. This means that the probe tip must be below 0.1V while sinking 2.1mA. Well, the Volmax for 74xx is 0.4V at 16mA and for 74LSxx it is 0.5V at 20mA.

    So there is a quite good likelihood that this probe will not properly indicated perfectly valid logic levels.
     
    absf likes this.
  3. Mike C

    Thread Starter New Member

    Feb 11, 2015
    6
    0
    You're right on that 2.7 volts. I hadn't even considered that. I was just probing the +5 and ground to test low and high. Ok I will simply chalk this up as a very bad example.

    I've included the document again with page 13 as well just for completeness. I appreciate the help and the confirmation that I wasn't doing anything wrong.

    Mike
     
    • lab2.pdf
      File size:
      433.6 KB
      Views:
      67
Loading...