LM331 VFC Output Problem

Discussion in 'General Electronics Chat' started by syee10, Oct 5, 2010.

  1. syee10

    Thread Starter Member

    Mar 26, 2010
    59
    0
    Hi,

    I have construct the Standard Test Circuit of LM331 Precision VFC circuit in Proteus. But i found that there is no output at pin 3,fout. There is no error message when i run the circuit. What device should i use to display the output at pin3 fout which give me the frequency? I had attached the Standard Test Circuit of LM331 in the Datasheet and the Circuit i contruct using Proteus.
    Thanks
     
  2. bertus

    Administrator

    Apr 5, 2008
    15,647
    2,346
    Hello,

    You will not see any signal at pin 3 without a pull-up resistor, as it is an open collector output.

    [​IMG]

    In the schematic (you posted) from the datasheet there is a 10K resistor from pin 3 to the Vlogic.

    Bertus
     
    Last edited: Oct 5, 2010
  3. syee10

    Thread Starter Member

    Mar 26, 2010
    59
    0
    Bertus,

    Is my connection Correct rite now? I should get a range of 1-10kHz frequency output at the pin3,fout. Now my problem is what device should i use to display the output frequency waveform? Sorry i am newbie in this =(
     
  4. bertus

    Administrator

    Apr 5, 2008
    15,647
    2,346
    Hello,

    Yes, the connections are OK.
    You can check the shape of the signal with an oscilloscope.
    The frequency of the signal can be checked with a frequency counter.

    Bertus
     
  5. syee10

    Thread Starter Member

    Mar 26, 2010
    59
    0
    I cant find a frequency counter in Proteus? ><
     
  6. bertus

    Administrator

    Apr 5, 2008
    15,647
    2,346
    Hello,

    I am not familair with simulation software.
    Perhaps the oscilloscope can measure the frequency too.

    Bertus
     
  7. Ron H

    AAC Fanatic!

    Apr 14, 2005
    7,050
    657
    You have a missing connection, or a poorly drawn schematic. See
    attachment.
     
    • ckt.PNG
      ckt.PNG
      File size:
      129.8 KB
      Views:
      86
  8. syee10

    Thread Starter Member

    Mar 26, 2010
    59
    0
    Ron,

    My connection are well connected. I checked every pin and already make sure the connections are correct.
     
  9. syee10

    Thread Starter Member

    Mar 26, 2010
    59
    0
    Bertus,

    The problem now i having is i cannot obtain the output even i connect a frequency meter at the output pin. Any idea?
     
  10. syee10

    Thread Starter Member

    Mar 26, 2010
    59
    0
    I had tried to simulate the simplest LM331 standard test circuit. This time i get the frequency output when i connect frequency meter to it. But weird i only get output when my input voltage is ZERO. The frequency meter did not show any figure(output) when my input is not ZERO!!Help me please?
     
  11. bertus

    Administrator

    Apr 5, 2008
    15,647
    2,346
    Hello,

    Did you implement the connection Ron H talked about.
    Without that connection the capacitor can not work.

    [​IMG]

    Bertus
     
    • VCF.png
      VCF.png
      File size:
      15.2 KB
      Views:
      149
Loading...