LG 42" LCD TV 42LG20-UM No video ONLY sound BAD inverter board or bad power board?

Discussion in 'General Electronics Chat' started by arman960, Sep 16, 2012.

  1. arman960

    Thread Starter New Member

    Sep 16, 2012
    5
    0
    I can see the lcd working with flash light on it. But no picture because of no inverter. The inverter is not turning on, I don't know if it is bad or power boards is bad.

    Looks like inverter getting 24v from power board. But output voltage from power board only 1.9v to T-con. This output suppose to be 3.4v

    My question, is it possible that inverter not turning on because t-con main board is not getting 3.4v or my both inverter board bad?

    I am stuck, don't know if the inverter board bad or bad power board.:mad:
     
  2. THE_RB

    AAC Fanatic!

    Feb 11, 2008
    5,435
    1,305
    The most common reason for the tube inverters to not fire up the tubes is bad caps. Sometimes if you warm the inverter with a hair dryer it will fire up ok, that is a perfect symptom of bad electro caps in the inverter. It's usually the smaller electro caps near heatsinks, 10uF is a particularly bad value.

    Also I should warn you that working on monitors and TVs can be dangerous, BE VERY CAREFUL or get it fixed by a professional!
     
  3. Dodgydave

    Distinguished Member

    Jun 22, 2012
    5,000
    745
  4. arman960

    Thread Starter New Member

    Sep 16, 2012
    5
    0
    I cannot swap the inverter. right and left is different. They don't match. This is LCD TV inverter.
     
  5. Dodgydave

    Distinguished Member

    Jun 22, 2012
    5,000
    745
    take a note of the part numbers on the pcb and do a search.
     
  6. arman960

    Thread Starter New Member

    Sep 16, 2012
    5
    0
    Here is the pictures. Power going to inverter boards and power going to t-con/mainboard

    I am getting 24V for inverter board. But they are not firing up. I am also getting only 1.9v for t-con output where it should be 3.4V on

    So I want to know if my inverter boards are bad or my power board faulty.

    The tv turns on with sound and faint picture can be seen with flash light. TV was working couple days ago.
     
  7. Dodgydave

    Distinguished Member

    Jun 22, 2012
    5,000
    745
    The inverter pcbs are the two boards in black on the edges they look identical, the pcb in the middle under the metal shield is the main signal pcb, and the yellow pcb is the smps or power supply board, the inverters look like the one i gave in my post #3
     
    Last edited: Sep 16, 2012
  8. arman960

    Thread Starter New Member

    Sep 16, 2012
    5
    0
    So is it possible that both inverters dies same times? is it possible to get back light with only one good inverter?
     
  9. Dodgydave

    Distinguished Member

    Jun 22, 2012
    5,000
    745
    highly unlikely both boards are faulty, one has possibly gone down and the current limit may have shut down the supplies, try unplugging one of the inverters, it may work on one board.
     
  10. arman960

    Thread Starter New Member

    Sep 16, 2012
    5
    0
    Yes that is the Inverter board on ebay. I can buy both from ebay for a reasonable price. But I want to make sure it is Inverter board not the power supply board that is faulty.


    I checked with one inverter at a time hooked up with the board. No sign of back light. Is it possible that my main board is faulty. I get picture with flash light, two second test.
     
  11. Dodgydave

    Distinguished Member

    Jun 22, 2012
    5,000
    745
    sounds like current limit is kicking in,must be a short some where.
     
  12. Miggz10

    New Member

    Jun 18, 2013
    1
    0
    I'm having the same problem on a LG 52LB5D.
    HELP!
    Do both inverter boards do the same thing or is one slightly different from the other, how do i find out which one is the faulty one?
     
  13. sheldons

    Well-Known Member

    Oct 26, 2011
    616
    101
    your set uses master and slave invertor boards-if either board is faulty the protection circuit monitored by the ssb board will remove the supply and prevent both boards from working-it may also be that the power on signal from the ssb is missing due to a missing supply either on the ssb board or from your power supply panel itself-may be oc circuit protector or faulty regulator etc-check on power up if the invertor supply comes up then goes off and check the power on signal from your ssb is working.
    Another fault may be the backlight assy itself -this is where a stand alone ccfl tester is handy
     
Loading...