LED Museum gone.

Discussion in 'General Electronics Chat' started by Wendy, Mar 30, 2010.

  1. Wendy

    Thread Starter Moderator

    Mar 24, 2008
    20,766
    2,536
    I liked this site too, it had some really good information.

    Anyone know how to contact the person who made it? Or maybe where it moved to? I looked, and couldn't find it.

    http://ledmuseum.home.att.net/museum.htm
     
  2. bertus

    Administrator

    Apr 5, 2008
    15,648
    2,346
  3. Markd77

    Senior Member

    Sep 7, 2009
    2,803
    594
  4. retched

    AAC Fanatic!

    Dec 5, 2009
    5,201
    312
    Yup, Mark77. Bill_Marsden should be happy to see the link. I couldn't imagine Craig up-and-ending the museum. He would at LEAST try to find a new curator. He has just HUGE amounts of information available.

    Spectral Analysis for hundreds of leds.. Just a great site.

    The man loves his LED flashlights.
     
  5. Wendy

    Thread Starter Moderator

    Mar 24, 2008
    20,766
    2,536
    I must have caught them in an off moment, it was moving extremely slow, bad enough I was worried about malware.

    I liked the old site much better, but beggars can't be choosers.
     
  6. SgtWookie

    Expert

    Jul 17, 2007
    22,182
    1,728
    Traffic from China is placing a huge burden on bandwidth lately.

    If they could turn that off, response would be vastly improved.
     
  7. JDT

    Well-Known Member

    Feb 12, 2009
    658
    85
    Thank goodness!

    I sent him some very old LEDs once. They had 3 leads!

    He seemed very pleased and were featured on the site.

    The world needs people like this. Bookmarked and hope the site keeps going as long as possible.
     
  8. telephony

    New Member

    Jul 27, 2016
    3
    0
    I'm the curator/product tester of this 16.5+ year-old website.
    The website has moved again; the new URL is http://www.ledmuseum.net

    Enjoy mo capitan! :)
     
  9. bertus

    Administrator

    Apr 5, 2008
    15,648
    2,346
    Hello,

    The link does not work.
    A blank page is shown.

    Bertus
     
  10. ScottWang

    Moderator

    Aug 23, 2012
    4,854
    767
  11. telephony

    New Member

    Jul 27, 2016
    3
    0
    I reuploaded the /index.htm web page to my server; all appears right as rain now.

    If you still can't get in, there may be an issue with redirects on the internet in your vicinity; try http://www.ledmuseum.net/ledleft.htm and see what happens (this entry also bypasses my splash screen so you can get straight to the meat and potatoes).

    --Craig
     
  12. telephony

    New Member

    Jul 27, 2016
    3
    0
    This URL only displays the left-frame menu; things will look somewhat fuxxored if you enter my website via this URL. :-O
     
Loading...