KiCAD and filled zones fail

Discussion in 'The Projects Forum' started by simo_x, Apr 5, 2015.

  1. simo_x

    Thread Starter Member

    Dec 23, 2010
    200
    6
    Hi all !

    I am designing the PCB of my home made function generator, but I have a problem making a GND plane on the front side of my 2 layer PCB.

    After filling zones especially near bypass capacitors, after tracing the GND plane and filling it, KiCAD doesn't mind about the filled zones, he doesn't care if there are filled areas or not. He directly place the GND plane over the filled areas, making a straight short circuit...

    I attach a snapshot of my PCB where we can see a short circuit between GND and +2.5 V.

    kicadFail.png

    Do you know how I can fix this problem ? I don't know it this is a known bug but I would like to place filled areas near bypass capacitors..

    I also put a GND plane on the back/lower side of the PCB.

    Thank you in advance.
     
  2. jpanhalt

    AAC Fanatic!

    Jan 18, 2008
    5,672
    899
    I am not a KiCAD user. But your problem seems generic. In Eagle, every fill has a priority. You need to change the priority to keep fills from overlapping each other. I am sure KiCad has a similar feature. I can't imagine a PCB CAD program that wouldn't allow that. It just may not go by the same name.

    John
     
    simo_x likes this.
  3. simo_x

    Thread Starter Member

    Dec 23, 2010
    200
    6
    Hi !

    Your explanation seems right. Unfortunately I don't use Eagle. And I don't know how to set this property in KiCAD. :(

    I take a look in Google. I will update this post but while I am looking I will appreciate all the incoming suggestions (if they will be).
     
  4. simo_x

    Thread Starter Member

    Dec 23, 2010
    200
    6
    Last edited: Apr 5, 2015
  5. simo_x

    Thread Starter Member

    Dec 23, 2010
    200
    6
    I installed KiCAD on Windows and yes, there is the priority option.
    There is not for the version on Linux. Quiet strange...
     
  6. MaxHeadRoom

    Expert

    Jul 18, 2013
    10,500
    2,366
    Can you use the Zone Cut out to delete the part of the offending zone?
    Max.
     
  7. simo_x

    Thread Starter Member

    Dec 23, 2010
    200
    6
    Hi Max,

    I did not try it but I think I would spend more time cutting the offending areas than finishing it using the Windows version.

    But I repeat, it seems to me quiet strange I can't set priority level on Linux version.
    I updated it two days ago.. At the same time I downloaded the Win version.

    Next time I will set up Eagle and I will do my works on it.
     
  8. simo_x

    Thread Starter Member

    Dec 23, 2010
    200
    6
    I solved also for Linux. I don't know what the hell I did with the updating of the version I had installed before, but now works fine.
     
Loading...