JTAG cant work for STRATIXII

Discussion in 'General Electronics Chat' started by CindyGirl, May 15, 2008.

  1. CindyGirl

    Thread Starter New Member

    May 15, 2008
    2
    0
    I used jtag mode to debug Stratix II FPGA for days, and yesterday I pluged off the jtag header with power off and later pluged in again(still with power on). Quartus reported error"cannot detect scan chain".

    Active Serial programming mode is still ok, and there are no short-circuits among the Gnd and powers. I test the TDI, it is pulled up to 3.3v in the board and should be high duiring FPGA working. However TDI stays low.

    Is my FPGA ok? I am really puzzled with this problems. Need your help badly.

    Thanks

    Cindy
     
  2. ametso

    Member

    Apr 30, 2008
    13
    0
    Hi

    Unfortunately I suppose that your FPGA is dead. I mean that FPGA is broken from JTAG port. It is not first of time that JTAG in/output buffers get hurts from the ESD spike when the JTAG cable is attached to connector (This is sound of experience after four burned FBGAs).

    Nowadays - I have learned that the JTAG port also needs ESD protections on the traces.
     
  3. CindyGirl

    Thread Starter New Member

    May 15, 2008
    2
    0
    Hi friend,

    Thanks for your reply, and sorry for your four burned FPGA.:(

    I have tested the I/O pins in the same bank with TDI, they appearred alright. The phenomenon is so weried that only one pin in the bank is hurt. :confused:

    what did you do with these FPGA, will they work if they are programmed by Active Serial Programming?

    Thanks for you help again.

    Cindy

     
Loading...