JDM hardware help

Discussion in 'Embedded Systems and Microcontrollers' started by chrischristian, Mar 30, 2008.

  1. chrischristian

    Thread Starter Active Member

    Feb 22, 2008
    43
    0
    Hi!
    I have made a JDM programmer and now trying to test it according to:
    http://reprap.org/bin/view/Main/StripboardJDM#Testing

    The circuit seems to be O.K. on first test ( it shows 4.20V) but, then I tick the enable data out the data in does'n get ticked and I get 0.01V between pin 5 and 13, don't know what to do. Please help I have spend money on this and 16F628 and will be my first MCU so, this has to work!!

    The JDM schematic I used is attached, the clock LED blink when I turn on my PC.
     
  2. dclermont

    New Member

    Mar 13, 2007
    6
    0
    I'm not an expert but you are using "power stealing" from the RS232 port, you are using it to drive LED's! -- try disconnect the LED's first to see if it works.
     
  3. beenthere

    Retired Moderator

    Apr 20, 2004
    15,815
    282
    Be nice is that big untested design disclaimer wasn't at the top of the page.

    Pin 5 & 13 of what? The PIC or the serial port?
     
  4. dclermont

    New Member

    Mar 13, 2007
    6
    0
    Looking at CHRICRISTIAN post, he is changing the original JDM to add bell and whistle like LED as depicted in his thumbnail attachment as I stated if he try to drive LED from this, there will not be enough energy to keep the LED and the rest of the circuit power together.
     
  5. chrischristian

    Thread Starter Active Member

    Feb 22, 2008
    43
    0
    Removing LEDs didn't solve the problem in fact the 4.20 V I was getiing between pin 5 and 14 is now 5.20V, I think the problem was not LEDs, I have used BC 558 insted of BC550C but I don't think that can cause trouble or can it? Should the DATA IN get ticked when I tick DATA OUT, even when MCU is not in the socket? I also found that when I measure voltage between pin 5 and pin 4 it shows 4.45 volts and when I tick ENABLE MCLR in ic prog hardware check wizard it swings to 0.02V while it should be 12V as per http://reprap.org/bin/view/Main/StripboardJDM#Testing. Please any one have ever made tis JDM programmer, help me!!!!
    IN ALL ABOVE TEST IC SOCKET IS EMPTY!
     
  6. chrischristian

    Thread Starter Active Member

    Feb 22, 2008
    43
    0
    After the last post I tried to change the schematic of JDM to it's actual one from ic-prog. and now when i tick DATA OUT the DATA IN get ticked but, still not having MCLR and other thing write, please see the link given, from which I am testing the JDM.
    http://reprap.org/bin/view/Main/StripboardJDM#Testing

    scematic also on the same link. PLEASE HELP ME :(
     
Loading...