IR2304 H Bridge mosfet driver problem.

Discussion in 'General Electronics Chat' started by iamhere, May 27, 2009.

  1. iamhere

    Thread Starter Active Member

    May 1, 2009
    33
    0
    Hello everyone,

    I meet problem when I use IR2304 to drive half bridge, attached the picture of schematic:

    PB0 & PB1 with PWM (25Khz-100khz) signal input from MCU( high level time about 47%, low level time+ deadtime 53%).
    Q2 & Q3 are IRF830.
    V400 about 340v when PFC not running, near 400v when PFC running. PFC will run when CV3 charged.

    [​IMG]

    In my first test , I use a 12V transformer to provide both V16 and V400 with 12v power, test result show the circuit run very well, the nice square wave checked on 'Drain' of Q3 . the IR2304 is quiet.

    In my second test, I connect V400 to high voltage (300v-400v), and connect V16 to V400 through a 30K resistor for the purpose of supply start power, and expect the CS1 (1nF) can provide power to IR2304 when running, but failed. no voltage tested on 'Drain' of Q3. Voltage of CV3 =0, the IR2304 is soniferous with sound 'z, z , z '

    In my third test, I connect V400 to high voltage (300v-400v), and connect V16 to 12v transformer, I tested there are voltage on 'Drain' of Q3, but seems abnormal( I can not test the wave as it is high voltage). Voltage of CV3 =0, the IR2304 is soniferous with sound 'z, z , z ' ,


    would you like to help me checking where may cause problems? any suggestions or tips will be thankful.

    Regards
     
    Last edited: Jun 1, 2009
  2. R!f@@

    AAC Fanatic!

    Apr 2, 2009
    8,733
    759
    If you want help., post a clear schematic buddy and details of the problem
     
  3. radiohead

    Active Member

    May 28, 2009
    474
    31
    Try a different MOSFET like an IRF510 for example.
     
  4. iamhere

    Thread Starter Active Member

    May 1, 2009
    33
    0
    So can somebody tell me a good way to power the IR2304? thanks a lot.
     
    Last edited: Jun 1, 2009
  5. iamhere

    Thread Starter Active Member

    May 1, 2009
    33
    0
    voltage on bridge will be near 400V
     
  6. iamhere

    Thread Starter Active Member

    May 1, 2009
    33
    0
    please click the picture.
     
Loading...