HELP needed on 37LF65 Lcd Tv problem

Discussion in 'General Electronics Chat' started by Welshy_Pete, Nov 5, 2011.

  1. Welshy_Pete

    Thread Starter New Member

    Nov 5, 2011
    17
    0
    Hello Ive got a 37lf65 lcd tv. The tv switched on and works fine the picture as it should. Then after afew mins or so it will start clicking or poping sounds then the screen goes blank. But the tv stays on the green light but then no sound or picture.

    If I switch the tv on and of it will work fine but then do the samething again. But will do it more faster when it gets warmer.

    Ive tried anther mains cable but its still the same problem.

    Just wandering is this the part power board needed or something else gone?

    thanks pete
     
  2. Welshy_Pete

    Thread Starter New Member

    Nov 5, 2011
    17
    0
    Model LG 37LF65
     
  3. sheldons

    Active Member

    Oct 26, 2011
    616
    101
    ok failure could well be power supply related-there may also be a chance of a fault to do with your inverter-worst case may be a failing backlight assembly(insulation problems occur here with the wiring used)
    faults like this can also cause corruption with the sets nvm as well which can cause some very weired faults.
     
  4. sheldons

    Active Member

    Oct 26, 2011
    616
    101
    you need to check the smps for hi esr and bulging leaking capacitors as a start....they will be obvious to spot.....
     
  5. R!f@@

    AAC Fanatic!

    Apr 2, 2009
    8,754
    760
    u need to open it up.
    Have u got any experience in this kinda work?
     
  6. sheldons

    Active Member

    Oct 26, 2011
    616
    101
    basically lie the set screen down(if you dont have a servicing jig)on something soft like a blanket etc and examine the power supply for overheated bulging capacitors-which will be easy to spot.....always replace these with hi temp types to stop repeated failure and replace with a higher voltage (some sets use 10v rated capacitors on a supply rail of some 12v dc-which do fail after a while)do NOT connect any test equipment(along the lines of a scope etc)without using an isolation transformer....quick tests with yr multimeter will be fine
     
  7. Welshy_Pete

    Thread Starter New Member

    Nov 5, 2011
    17
    0
    Just anther update I left the tv of all night and unplugged. Just plugged in back in the Tv stayed on for 25mins also the room cool with the window open. Once it got warm it started again. Switch it back on and it would go of within 30 seconds.

    Ive taken the power board out and thinking of getting it checked out then a replacement one if found faulty.

    So this is deffo a heat related power board problem now?
    __________________
     
  8. sheldons

    Active Member

    Oct 26, 2011
    616
    101
    ok heres all i have at present service manual wise for this model:D
     
  9. Welshy_Pete

    Thread Starter New Member

    Nov 5, 2011
    17
    0
    Ive got the tv open up and too the mains power board out. Still got the back of the tv of.
     
  10. Welshy_Pete

    Thread Starter New Member

    Nov 5, 2011
    17
    0
    Ive checked the capacitors on the main power board and the all look fine. None have any leaks or bulges or domed either.
     
  11. sheldons

    Active Member

    Oct 26, 2011
    616
    101
    ok have a look on the invertor board....and check each invertor transformer with your dvm and see whats happening with them
     
  12. Welshy_Pete

    Thread Starter New Member

    Nov 5, 2011
    17
    0
    LCD TV Troubleshooting
    The defective LCD TV may have the following common symptoms:
    Symptom: No picture on screen but LCD TV still has sound.
    Solutions: The problem is cause by defective inverter. Replacing ivnerter will solve hte problem.
    --------------------------------------------------------------------------------
    Symptom: Screen flash on and off between 1/2 to a few seconds, but power indicate light stays on and TV still has sound.
    Solutions: The problem is cause by defective inverter.
    --------------------------------------------------------------------------------
    Symptom: Blue Screen but no picture
    Solutions: The problem is cause by defective Main Board(AD Board). In some cases, this problem may cause by the defective Screen Controller board. Thsi board is mounting on teh back of LCD TV Screen.
    --------------------------------------------------------------------------------
    Symptom: Power light stays on but no display and sound
    Solutions: The problem is cause by defective Main Board(AD Board) or Power supply board.
    --------------------------------------------------------------------------------
    Symptom: No Power or Power indicate light does not lits
    Solutions: The problem could cause either by defective Power supply board or defective Main Board(AD Board).
    --------------------------------------------------------------------------------
    Symptom: Screen is half dim and half bright
    Solutions: The problem is cause by defective LCD Panel.It needs to be replace.
    --------------------------------------------------------------------------------
    link
    http://www.lcdparts.net/panelledkit.aspx
     
  13. Welshy_Pete

    Thread Starter New Member

    Nov 5, 2011
    17
    0
    Mine is that

    Symptom: Power light stays on but no display and sound
    Solutions: The problem is cause by defective Main Board(AD Board) or Power supply board.

    But mine works when cool for 25mins then goes of. Then when switched back on goes of faster warmer.

    So the power supply board which I know of. But whats the main board ad board????
     
  14. sheldons

    Active Member

    Oct 26, 2011
    616
    101
    ok have a look in the service manual page 53 that is the board you need to look at....it may be useful if you have a hairdryer and heat various components up and see if the fault clears then use some freezer spray to cool the component down again...it could still be a hi esr or oc capacitor but also it may be soldered joints or a fault with the backlight assy itself
     
  15. sheldons

    Active Member

    Oct 26, 2011
    616
    101
    do not heat parts up while the set is on by touching them with the tip of your soldering iron or things will go bang(without the use of an isolation transformer)
     
  16. R!f@@

    AAC Fanatic!

    Apr 2, 2009
    8,754
    760
    Please..please post pictures before u go on. This would help in telling u where to look.
     
  17. Welshy_Pete

    Thread Starter New Member

    Nov 5, 2011
    17
    0
    Ive had a look on the back of the soldered joints and there metal parts which stick up. Then there small parts of metal missing this could be the problem. Ive cleaned the back of the mains power board. I will post some pictures on here to show what you all think.
     
  18. Welshy_Pete

    Thread Starter New Member

    Nov 5, 2011
    17
    0
    Just looked at the back of the psu board and the solders have bits missing on them. I think this could well be the problem. Also maybe faulty capicitors. But the broken solderder links would cause problems?

    I will post some pictures now best I can.
     
  19. Welshy_Pete

    Thread Starter New Member

    Nov 5, 2011
    17
    0
    Pictures of the power board on the back the solders have parts missing or flat gone.

    [​IMG]

    [​IMG]
     
  20. R!f@@

    AAC Fanatic!

    Apr 2, 2009
    8,754
    760
    Sorry mate. I cannot see any issue there.

    U need to post complete board and take the picture perpendicular to the board.

    I need to look at both sides
     
Loading...