Help MOSFET need replacing .

Discussion in 'General Electronics Chat' started by rastaman46, Aug 24, 2013.

  1. rastaman46

    Thread Starter Member

    Nov 17, 2011
    69
    0
    Hi

    I got car universal laptop charger that had short and now 12V just flow true without boost.

    Its one of them chargers

    [​IMG]

    I took it apart and found one mosfet is Cracked
    Mosfet "P60N06"

    I removed it so got question here what i can use to replace it?

    Thanks
     
    Last edited: Aug 24, 2013
  2. #12

    Expert

    Nov 30, 2010
    16,284
    6,797
    rastaman46 likes this.
  3. rastaman46

    Thread Starter Member

    Nov 17, 2011
    69
    0
  4. ScottWang

    Moderator

    Aug 23, 2012
    4,854
    767
    MTP60N06 - 60V/60A/14mΩ.

    NTP60N06 - 60V/60A/14mΩ.

    I just wondering does this adaptor really need the current as this mosfet?
    
    
     
    rastaman46 likes this.
  5. rastaman46

    Thread Starter Member

    Nov 17, 2011
    69
    0

    I got loads 12V chargers is any way i can remove mosfets from there and use it as replacment?

    i got Mosfets "STPS3045CT" "K2842"

    All i want to do is just make it run from stuff i can get NOW cause i need it for fishing tomorrow night :D

    I can buy but ill take few days to receive it that all

    all i want is make it run for atleast 19V
     
  6. ScottWang

    Moderator

    Aug 23, 2012
    4,854
    767
    STPS3045CT - POWER SCHOTTKY RECTIFIER.

    2SK2842 - N channel MOSFET 500V/12A/0.4Ω
     
    rastaman46 likes this.
  7. LDC3

    Active Member

    Apr 27, 2013
    920
    160
    STPS3045CT is not a transistor.

    K2842 will work as long as the current is below 12 A continuous, or 40 A pulse (provided you stay below the heat dissipation required).
     
    rastaman46 likes this.
  8. rastaman46

    Thread Starter Member

    Nov 17, 2011
    69
    0

    Thanks for answer

    Replaced but still only 12V true no boosting :(

    Can any one tell me what can cause it ?

    Screens:

    [​IMG]

    [​IMG]
     
  9. wayneh

    Expert

    Sep 9, 2010
    12,123
    3,047
    It's a little hard to tell but that IC on the back doesn't look so good. Might be toasted.
     
  10. LDC3

    Active Member

    Apr 27, 2013
    920
    160
    To the far right of the IC, is there a bridging solder connection?
     
  11. rastaman46

    Thread Starter Member

    Nov 17, 2011
    69
    0
    No not Bridged

    It was working till it got short and after that all i get is 12V

    12V in and 12V out even if its set to 24V :confused:

    All i notice is that 8 feet transistor gets hot but coil do not
     
    Last edited: Aug 24, 2013
  12. wayneh

    Expert

    Sep 9, 2010
    12,123
    3,047
    Do you mean the 8-pinned IC on the back that I asked about? I'm thinking it might be dead. Can you read the lettering on it?
     
    rastaman46 likes this.
  13. rastaman46

    Thread Starter Member

    Nov 17, 2011
    69
    0

    Yes that IC get HOT

    IC number: 3843B
     
  14. rastaman46

    Thread Starter Member

    Nov 17, 2011
    69
    0
    Sorted thanks for help!

    Trow it in bin got other one of my m8

    Happy fishing again!!!
     
  15. wayneh

    Expert

    Sep 9, 2010
    12,123
    3,047
    Ah yes, the serenity of accepting what we cannot change. Hope they're biting! :D
     
Loading...