Help identifying specific SMD components [images]

Discussion in 'General Electronics Chat' started by rumachik, Mar 19, 2012.

  1. rumachik

    Thread Starter New Member

    Mar 16, 2012
    2
    0
    Hello,

    I have a MIDI pad (an Akai MPD32) that has two blown components: U10 and U12. Here are two pictures of U10 and one of U12:

    http://www.flickr.com/photos/78040625@N03/6842650544/ (U10)
    http://www.flickr.com/photos/78040625@N03/6842650798/ (U10) (you can see the bottom of U12 in this one)
    http://www.flickr.com/photos/78040625@N03/6842650592/ (U12)

    I am fairly certain this is part of the power supply, if that helps at all. Does anyone have any idea what they might be (I am looking for part numbers, specifically)?

    Thanks for any help!
    Carl
     
  2. THE_RB

    AAC Fanatic!

    Feb 11, 2008
    5,435
    1,305
    Probably voltage regulators, and when they have blown so very severely there are probably other ICs in the device that are destroyed too.

    Even an expert would probably turn that repair down and say it's not worth trying to fix...

    Otherwise if you must try to fix it you can probably get a service manual and/or schematic from the internet, Akai stuff was usually well supported. That will show the parts values.
     
  3. t06afre

    AAC Fanatic!

    May 11, 2009
    5,939
    1,222
    How did you fry it so bad? I agree with The_RB. Other compontes will for sure be damaged to. it is most probably a goner
     
  4. THE_RB

    AAC Fanatic!

    Feb 11, 2008
    5,435
    1,305
    Yep. It's unlikely to have happened from a mild overvoltage situation, more likely a reverse polarity fault followed by a massive reverse overcurrent fault... Closely followed by a melting smoke-generating fault... :eek:
     
  5. rumachik

    Thread Starter New Member

    Mar 16, 2012
    2
    0
    Thanks for the replies. I do not know how the board was damaged. I bought it off eBay for cheap with the intent of fixing it--usually with these devices it's just a loose USB or DC jack or a pinched cable or something.

    I "emailed" Akai (via their web form) a couple weeks ago and unfortunately have not heard back. I can't find any schematics or any info on this device's internals either.

    No other components on any of the boards are visibly damaged, which I realize doesn't prove anything, but I figured I would give it a shot.

    I cannot find either component in the Turuta databook or SMD codebook...or elsewhere on the internet. I would have thought the LDO would be fairly easy to identify, as its markings all appear intact. I am not even sure what kind of IC U10 is though...
     
Loading...