hall sensors output

Discussion in 'General Electronics Chat' started by jayanthyk192, Nov 14, 2010.

  1. jayanthyk192

    Thread Starter Member

    Jan 23, 2010
    80
    0
    Hi,

    what is the voltage change the occurs when a magnet is brought near an hall effect sensor?

    these were my observations of a cdrom hall effect sensor.
    1)voltage input=5V.output voltage around 1.52v.
    2)when a magnet is brought near,0.06 volts change in out put.
    3)the weird thing that happened was that even when i changed the polarities,the output was same.
    then i used the attached circuit.i used LM324 for the circuit.then things got worse.i connected 5V to pin4 and gnd to 11.the output of each opamp was locked in 3.72V(around).

    what went wrong with the opamp?does the hall sensor in cdrom give 0 when no magnet and 1 if magnet is present?please give me a circuit the gives digital output for hall sensor input(if the hall sensor does not give digital output)while connecting the hall sensors,i checked the pin connections and found two pins to be common to all and gave voltage to it.was i correct?i connected hall sensors in parallel.

    thank you.
     
  2. hgmjr

    Moderator

    Jan 28, 2005
    9,030
    214
    What is the part number of your hall effect sensor?

    hgmjr
     
  3. thatoneguy

    AAC Fanatic!

    Feb 19, 2009
    6,357
    718
    Are you using the magnet from the CD ROM drive?
     
  4. jayanthyk192

    Thread Starter Member

    Jan 23, 2010
    80
    0
    the sensor has no number written on it.it has a symbol that resembles an AND gate

    yes, i tried using the cdrom motor's outrunner as well as a flat magnet but no change was seen.
     
  5. Kermit2

    AAC Fanatic!

    Feb 5, 2010
    3,795
    951
  6. jayanthyk192

    Thread Starter Member

    Jan 23, 2010
    80
    0
    i could'nt get much info regarding the hall sensor of my cdrom.for now i'll leave the hall sensor behind and concentrate on opamp.as mentioned eariler each opamp was in high state even without connecting it any hall sensor(except for Vcc and gnd)what's going wrong?
     
Loading...