H-bridge problem with MOSFET

Discussion in 'The Projects Forum' started by asadmosab, May 20, 2016.

  1. asadmosab

    Thread Starter New Member

    May 20, 2016
    2
    0
    This is my first project with MOSFET. I have built this design but the n-channel MOSFET getting hot. Is there mistakes I have made?

    I have no problems wit p-channel it measured -12V VGS and 200mv VDS, but with n-channel I have measured VGS about 11V and VDS about 4V --- the problem here is that in Multisim simulation VDS should be around 200mV, so from where this 4V come?
    I want to use this circuit with PWM.

    Thank you for any answer.
     
    Last edited: May 20, 2016
  2. ScottWang

    Moderator

    Aug 23, 2012
    4,855
    767
    How high the frequency you like to run with the pwm?
    Try to change all the 1K resistors to 10K.
    All 470Ω change to 100Ω or shorted.
    What is the IC number of inverter?
     
  3. asadmosab

    Thread Starter New Member

    May 20, 2016
    2
    0
    OK, I will. The inverter IC number is 74LS04N
     
  4. ScottWang

    Moderator

    Aug 23, 2012
    4,855
    767
    Then the Vcc of 74LS04 is 5V and A, B inputs all 5V level, so the R3, R11, R6, R16 change to 4.3Kor 4.7K.
     
  5. LEhenson

    Guest

    Mar 5, 2011
    3
    0
    Use a L298 or similar "H Bridge" = KISS (Keep It Simple Stupid)
    Mod edit: offensive language removed.
     
    Last edited by a moderator: Jun 1, 2016
  6. ScottWang

    Moderator

    Aug 23, 2012
    4,855
    767
    L298 only 2A, and the Load of H-bridge is 5Ω working in 12V then how is the I current?
     
    Last edited by a moderator: Jun 1, 2016
Loading...