Eagle questions

Discussion in 'General Electronics Chat' started by tracecom, Dec 25, 2010.

  1. tracecom

    Thread Starter AAC Fanatic!

    Apr 16, 2010
    3,869
    1,393
    I am trying (again) to learn Eagle 5.11.0 for Windows, and am making some slow progress. I went through the three lessons at Sparkfun, but found one problem I couldn't solve.

    In the SFE lesson 10, they have you create the symbol for an NCP1400, then create the package, and then mate the two parts. When I created the package and assigned the numbers to the pads, the numbers don't show up on the pads. They are assigned correctly because I was able to connect the pads of the package to the pins of the symbol. It's just that I can't see the numbers on the package. What am I doing wrong?
     
  2. Kermit2

    AAC Fanatic!

    Feb 5, 2010
    3,783
    943
    Do you have the layers ALL turned on?
     
  3. tracecom

    Thread Starter AAC Fanatic!

    Apr 16, 2010
    3,869
    1,393
    Yes, I should have stated that in my original post.
     
  4. TO2

    Member

    Jun 19, 2009
    26
    0
    Try to zoom in maybe? Make the window bigger.
     
  5. tracecom

    Thread Starter AAC Fanatic!

    Apr 16, 2010
    3,869
    1,393
    I tried that and had the package drawing filling the whole screen. No pad numbers to be seen. On the Sparkfun tutorial, the numbers almost fill each pad.
     
  6. jpanhalt

    AAC Fanatic!

    Jan 18, 2008
    5,685
    900
    I don't believe they show normally. At least they don't show in my versions, and I don't know why you would want them routinely to show (exception described below).

    If you take a standard package (open>library>chose a device) you will not see a pad number. If you use the Information button ("i") and click on a pad, then will see the name/number.

    If you want something to show, I would use one of the labeling layers and simply add a label to each pad.

    I sometimes do that when I am making a mixed board design with SMD and TH on the same side. Labeling pin#1 helps keep all of the mirroring straight in your mind. I usually use just a dot or something, not a number though.

    John
     
  7. TO2

    Member

    Jun 19, 2009
    26
    0
    Can you upload yours library then? I want to check it.
     
  8. tracecom

    Thread Starter AAC Fanatic!

    Apr 16, 2010
    3,869
    1,393
    I haven't done that before, but I'll try.
     
  9. Kermit2

    AAC Fanatic!

    Feb 5, 2010
    3,783
    943
    Top of window - OPTIONS menu/ open it - select 'set'

    select 'misc' tab / find check box 'display pad labels', or 'display pad names' I don't remember what the exact wording is, and put check mark there.
     
  10. TO2

    Member

    Jun 19, 2009
    26
    0
    The device symbol and package is good. I can see the pads when connecting the symbol to the package. See the pictures below.

    You can try to turn on only the top and tplace layer in the package editor. Make it easier to see in the device making section.
     
    • 1.png
      1.png
      File size:
      24.5 KB
      Views:
      16
    • 2.png
      2.png
      File size:
      25.5 KB
      Views:
      15
  11. tracecom

    Thread Starter AAC Fanatic!

    Apr 16, 2010
    3,869
    1,393

    That did it. Thanks.
     
  12. tracecom

    Thread Starter AAC Fanatic!

    Apr 16, 2010
    3,869
    1,393
    Apparently it was an option that I had to turn on. It's working now, but as long as you have the part, do you see anything I have done wrong?

    Thanks.
     
  13. TO2

    Member

    Jun 19, 2009
    26
    0
    Yes, the symbol pins LX and GND is not good, you should try to rotate it so that the pins is poiting to the outside.
     
  14. tracecom

    Thread Starter AAC Fanatic!

    Apr 16, 2010
    3,869
    1,393
    I didn't know what the green circles on the pins meant. I think it's fixed now. Thanks.


    When I had Windows Explorer open, I noticed a lot of files also named tracecom with numbers after them. Any idea what they are?
     
  15. TO2

    Member

    Jun 19, 2009
    26
    0
    I see it's fixed. The green circles are the connecting points of the device pins.

    The # files are backup files. Change .l#'number' to .lbr and you have the old library, handy in case you have done something wrong with the current library and saved it.

    board and schematic files also have automatic backup enable.
     
  16. tracecom

    Thread Starter AAC Fanatic!

    Apr 16, 2010
    3,869
    1,393

    Thanks again.

    I just noticed that when I added one of my NPE1400 devices to the schematic, it does not automatically number, e.g. U1. How do I fix that?
     
  17. tracecom

    Thread Starter AAC Fanatic!

    Apr 16, 2010
    3,869
    1,393
    John,

    I missed your reply earlier. I'll keep that in mind.
     
  18. TO2

    Member

    Jun 19, 2009
    26
    0
    I'm not really sure. But you could try to manual set the prefix when you make the device. The set prefix button is on the right side, just below the package window.
     
  19. SgtWookie

    Expert

    Jul 17, 2007
    22,182
    1,728
    Many IC's in the stock libraries use "IC" for the reference designator prefix. Rather than change them all, you might consider using "IC" for the prefix for the ICs you create.
     
  20. tracecom

    Thread Starter AAC Fanatic!

    Apr 16, 2010
    3,869
    1,393
    @ TO2 & Sgt

    Got if fixed thanks to you both.

    Eagle seems to be a very capable program, but it's not intuitive to me. And the libraries are complex and unverified. I don't know whether to try to use devices already created or try to start from scratch and make my own.

    Thanks also to K2 and John. It's nice to not have to puzzle everything out on my own.
     
Loading...