Eagle ground plane problem... please help!

Discussion in 'The Projects Forum' started by Redline870, Jan 7, 2016.

  1. Redline870

    Thread Starter New Member

    Nov 13, 2015
    22
    3
    I am working on creating my first circuit board with Eagle. This is my first time using Eagle so please bear with me and explain things like your talking to someone stupid(the stupid person being me).

    Drawing the schematic was easy but I keep getting errors with the DRC when trying to create a board. I am not concerned with the stop mask errors, but I keep getting a "width" error on layer 16, and it highlights the top line of the polygon that was drawn to create a ground plane. The only settings I changed was the width of the VCC and GND traces to be 50mils wide because when the device is first turned on, it spikes at around 1.6 amps then quickly settles to below.5 amps. I used the default auto router settings as I am not experienced enough to route the traces myself.

    I took pictures of the screen and the settings to hopefully help diagnose the problem:

    [​IMG]

    [​IMG]



    My last question although probably not as important is: Can I set the width of the polygon to be .01 or even 0? What effects, positive or negative, does it have on the board? It seems to surround the parts better when I do a width of 0 as shown here:

    [​IMG]
     
    Last edited: Jan 7, 2016
  2. Kermit2

    AAC Fanatic!

    Feb 5, 2010
    3,778
    932
    Not sure I understand what you want but I know eagle is frustrating to learn, but really good once you know it.
    My suggestion is to begin running the error checking routines after you have a good layout. This can take several iterations.
    Then rebuild the board one final time and start using the error checking after every 2 or 3 connections. If you have a problem you will find it immediately and can correct as you go.
     
  3. Redline870

    Thread Starter New Member

    Nov 13, 2015
    22
    3
    Sorry if I was unclear one of the pictures i posted was wrong... I do not have any issues with the board layout until the final few steps.

    If I do not create a ground plane and just use the autorouter followed by a DRC check, I come out with no width error.

    If I draw a polygon around the board, name it "GND", and then hit "ratsnest", it creates a ground plain (or ground pour as referred to in the tutorial). Then if I run the DRC check, I come back with a "width layer 16" error. If I click on the error message to highlight where the error is, it highlights the top edge of the polygon as being the error. I will include the correct picture of this below.

    [​IMG]




    This is the tutorial I watched for creating the board although I didn't do any manual routing:
    At 11:10 in the video he shows how to create a ground pour. I followed the steps exactly, but once I get to the DRC check it says width error on layer 16 and highlights the error as shown in the above picture.

    Is this more useful? If not let me know and I will take a video of exactly what I'm doing and post it to youtube so you can see. Thanks for your help so far...
     
  4. Redline870

    Thread Starter New Member

    Nov 13, 2015
    22
    3
    Here is another example with a different polygon. That one is a little further out from the edge of the board. No matter where I draw the polygon, it always highlights the top edge as being where the error is. It's so confusing too because I draw the polygon as a box around the board but the error is only with the top of it.

    [​IMG]
     
  5. JohnInTX

    Moderator

    Jun 26, 2012
    2,341
    1,024
    Eagle is fussy in DRC and some library components don't agree with the default DRC settings. Sometimes you can reduce the DRC clearance limits to get rid of lots of the errors - just make sure you're within the limits set by your board manufacturer.

    Width errors are common. I usually get lots of them, especially on the reference layers and text strings. I just click on each one in the error window, inspect it and APPROVE it when its not important The approval lasts until you edit the offending feature. I don't do as much PCB layout as I used to (just one last year) so I find its easier just to take things on a case by case basis rather than fiddle endlessly with DRC settings.

    The width of the fill polygon setting determines the width of the tracks that it draws to make the fill (its not a pour so much as a bunch of overlapping tracks). If the width is too big, you'll get a very coarse and lumpy fill as it tries to keep away from pads, traces etc. If the width is too fine, it will take much longer to draw the board and plot it. I usually use a fill track width that's maybe 50% of my finest feature (hole size etc) - sometimes a little more. A great way to see how its doing is to open the layer dialog on the toolbar, double-click the blue bottom layer in the Name column. That opens the color and fill style settings. Default is solid fill. Try one of the hatched or dotted styles. You'll see the tracks on that layer, including the fills, as hatched/dotted outlines and how they are drawn to keep clear of pads, etc. From there you can experiment with fill widths etc. and get something you like. You can change fill widths without recreating the poly by right-clicking on one of the outline traces (easier to find if its hatched) selecting Properties and changing the trace width right there. Be sure to save your file before messing with it...

    Have fun.
     
    Last edited: Jan 7, 2016
  6. SLK001

    Well-Known Member

    Nov 29, 2011
    812
    225
    When you pour a copper ground plane (or any signal pour), you can't draw the polygon with an outline at ZERO width. You must have a line width greater than 0.00". Try changing the line width of the polygon that defined the pour to as large as you can accept. The smaller the width, the larger the Gerber file. I have used line widths as small as 0.0005" for some pours.

    This is a problem when generating Gerbers, as a zero width Gerber can't be plotted.
     
Loading...