Dorji RF Receiver Problem

Discussion in 'Wireless & RF Design' started by Taban, Jul 5, 2013.

  1. Taban

    Thread Starter New Member

    Jul 5, 2013
    2
    0
    Hil all, i have a problem with Dorji Rf Receiver. My transmitter sends data in 53 second period but i cant receive them. I am taking rubbish signals. When i connect data pin to scope. I am seeing a screen like that

    DSC_0574.jpg

    I connected transmitter to logic analyzer and i saw data, it sends data well.

    Bit rate is 1024 Hz.

    My receiver's datasheet is here :

    http://www.wiltronics.com.au/datasheets/DORJI/RF-DRA886RX.pdf

    In addition. I cant see any data at logic analyzer.

    It is my RF receiver module an connections like below:

    All yellow cables go to ground and green one is Vcc and orange cable is data cable. I connect it to scope or PIC directly.

    DSC_0587.jpg

    What should i do ?

    Thanks for help
     
  2. bertus

    Administrator

    Apr 5, 2008
    15,648
    2,347
    Hello,

    A breadboard is not suitable for RF.
    The stray capacities of the breadboard will destroy all the RF signal.

    The following PDF will give you information on RF prototyping:
    rf_proto-1.pdf

    Bertus
     
  3. Taban

    Thread Starter New Member

    Jul 5, 2013
    2
    0
    Okey, thanks for sharing. I am reading that pdf
     
  4. upand_at_them

    Active Member

    May 15, 2010
    246
    29
    But he's not using the breadboard for RF, only the data which is 1024 Hz.

    Double check your connections, Tarban. You've got some fundamental mistake. Are you pulling the CS line low? Does it need a pullup so that it has a clean falling edge?

    It's not an RF issue.
     
    Last edited: Jul 6, 2013
  5. upand_at_them

    Active Member

    May 15, 2010
    246
    29
Loading...