Digital Dash Problems

Discussion in 'General Electronics Chat' started by BrownDog, Aug 30, 2013.

Thread Status:
Not open for further replies.
  1. BrownDog

    Thread Starter New Member

    Apr 30, 2013
    2
    0
    hey guys i have this digital dash from a hyosung motorbike and im currently fitting it to my car. no while working out the wires i dropped the speedo wire on the positive of the battery and well pretty much killed it.

    now if i connect the power it comes on for a second or two then turns off and one of the chips gets really hot, if i freeze it overnight i get a couple more seconds out of it.

    what has broken/fried, what can i do to fix it
     
  2. Wendy

    Moderator

    Mar 24, 2008
    20,766
    2,536
    The owners of All About Circuits has elected not to host discussions of automotive electrical system modifications/enhancements due to safety concerns, the potential of legal ramifications and the possible circumvention of vehicle regulations at the state and federal level.

    This thread is against the AAC forum rules, Chapter 6, as seen here:

    This can be found in our Terms of Service (ToS)

    Automotive modifications of any kind are strictly forbidden. Therefore, this thread will be closed.

    Please try to understand the reasons behind this action, and feel free to browse and use the forums.

    You might find answers to your questions in one of these forums:

    http://forum.allaboutcircuits.com/showthread.php?t=54400

    Another good forum that shares many of the same membership is http://www.electro-tech-online.com/ . Good luck.
     
Loading...
Thread Status:
Not open for further replies.