DCMD67 Control Board in Dunlop NK9000 Tredmill

Discussion in 'The Projects Forum' started by Old Timer2, Apr 2, 2015.

  1. Old Timer2

    Thread Starter New Member

    Apr 2, 2015
    3
    0
    Hi everyone, I am new here. I am an old timer who has played with basic electronics most of my life - but logic stuff I am not well up on.
    My problem is - when the treadmill is switched on, the belt will turn slowly - slower than a normal start 1.0 km /hr start. (as long as your not standing on it - when it may not move). When the speed up buttons are pressed - all the right responses happen - the beeps - the increase speed display on the panel, but absolutely no change in motor speed or mat speed.
    Elevate up and down works ok and everything else appears normal.

    From tests done - U11, the IBGT checks out ok. The IGBT optical driver, U9 - A 3020V checks ok. Looking for any voltage change at pin 3 of U9 (the LED Cathode) as the speed buttons are increased or decreased - absolutely no change. The mat motor does increase speed very slightly when a test meter lead is touched to pin 3 of U9.
    Pin 3 of U9 connects to a pin on U1 which is a Lattice LC4064V 75T44-101. The pin is 3rd to the right from the opposite corner to the circle denoting pin 1. I am presuming this pin is supposed sink voltage as the speed control is increased. For this reason I am suspecting a faulty U1 but looking for advise before I trash it.
    All help gratefully received - thank you.
     
  2. MaxHeadRoom

    Expert

    Jul 18, 2013
    10,526
    2,369
    Can you post the schematic or is it one of the common ones like MC-60/80 etc?
    Max.
     
  3. Old Timer2

    Thread Starter New Member

    Apr 2, 2015
    3
    0
    Thanks for your reply. Wish I could post a schematic but problem is I don't have one and no end of searching gives me any clue where to find one. I have taken a quick look at a pic of an MC-60 that you mention. Mine looks more complicated than that one. Here is a link to a pic of my one - second picture down. http://www.treadmillsrepair.co.uk/2014/03/endex-dcmd67-dcmd57-dcmd77.html Thanks so much for your help.
     
  4. MaxHeadRoom

    Expert

    Jul 18, 2013
    10,526
    2,369
    On many of these TM controllers that use an opto before the power semi it is a common problem of the opto becoming weaker, this may be borne out by the fact when you connect a meter lead to it you see a change?
    For the price it may pay to replace it.
    Max.
     
  5. Old Timer2

    Thread Starter New Member

    Apr 2, 2015
    3
    0
    Ok. Thanks for that, I will try a replacement opto. May take a week or so to get and fit. Will let you know.
     
  6. Joe Dixon

    New Member

    Apr 1, 2016
    2
    0
    did the opto fix the board ?
     
  7. MaxHeadRoom

    Expert

    Jul 18, 2013
    10,526
    2,369
    A Year has gone by and we have not heard back!;)
    Max.
     
Loading...