Custom Pspice Model

Discussion in 'General Electronics Chat' started by sailmike, Mar 11, 2014.

  1. sailmike

    Thread Starter Member

    Nov 11, 2013
    143
    3
    I need to create a custom Pspice model and I found a couple files on the manufacturer's website. I tried saving the .lib file and renaming it with the .lib extension and copying the file into Tools > Pspice > Library, but Pspice wouldn't recognize it. Obviously, I did it wrong. What's the correct procedure? I found the files at:
    http://www.nxp.com/search?rows=10&type=keyword&q=pht6nq10t&page=1&tab=Documents

    Thanks,
    Mike
     
  2. sailmike

    Thread Starter Member

    Nov 11, 2013
    143
    3
    I think I figured out how to create a custom part using the Model Editor. I changed the appearance of the part in Capture Part Editor. When I tried to use the part in a schematic for simulation I was unable to connect all the pins. You can see in the attached picture that I can't connect pin 3. How do I fix this?

    Thanks,
    Mike
     
  3. mvaseem

    Member

    Jan 31, 2014
    48
    8
    I think you need to turn on the Snap to Grid option in Capture.
    See attached image.

    - mvaseem
     
  4. sailmike

    Thread Starter Member

    Nov 11, 2013
    143
    3
    Gotcha. Thanks.

    Got another question: what's the difference between the two files for Pspice in that link I provided? Which one do I use for accurate simulations?

    Thanks,
    Mike
     
  5. mvaseem

    Member

    Jan 31, 2014
    48
    8
    Which one is accurate - can't be gauged by just looking at the files.
    The 2nd one atleast has the source (company name) and development date.
    I would prefer 2nd one.
     
Loading...