Creative SBS A335 volume control issues.

Discussion in 'General Electronics Chat' started by IrisD., Nov 11, 2013.

  1. IrisD.

    Thread Starter New Member

    Nov 11, 2013
    2
    0
    Hi, I've got a Creative SBS A335 speaker. For sometime, my right speaker gets muted and all the volume comes from the left speaker only. When I carefully turn the wheel sometimes the Volume works properly but if I crank it up it gets distorted again and the volume gets very low.

    And when I try to fix it by very slowly moving the wheel...some cracking voice starts up....then the volume just keeps on fluctuating. So I opened up the speaker and I found molten plastic over the wires. Is it normal?

    Please advise what to do.
     
  2. Alec_t

    AAC Fanatic!

    Sep 17, 2013
    5,805
    1,105
    If the 'wheel' is a volume or balance control its resistance track is probaly worn out.
    The 'melted plastic' looks like hot-melt glue used for anchoring wires etc. That's normal.
     
  3. #12

    Expert

    Nov 30, 2010
    16,343
    6,828
    It's called a worn out volume control. Either spray it with cleaner or replace it. Replacing is better because the spray cleaner is a temporary fix for carbon track controls. It only works really well on wire wound potentiometers, but you are not going to find that kind of quality in your speaker box.
     
  4. IrisD.

    Thread Starter New Member

    Nov 11, 2013
    2
    0
    THANX A LOT ALEC.T AND #12...

    I took in your advice and replaced the volume knob. Turns out the speaker's carbon wire was dirty...so I got the whole thing replaced and now it works just fine. :)

    Thanks a lot guys :)
     
Loading...